summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-11 20:21:54 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-11 20:45:30 +0100
commit5c235aa9aec58165a070a2d79b58a8bb3c0f88ba (patch)
treead5e788ad140ce8448c960d774551fb0eb483867 /media-video/videotrans
parentmedia-video/tovid: Depend on virtual/imagemagick-tools (diff)
downloadgentoo-5c235aa9aec58165a070a2d79b58a8bb3c0f88ba.tar.gz
gentoo-5c235aa9aec58165a070a2d79b58a8bb3c0f88ba.tar.bz2
gentoo-5c235aa9aec58165a070a2d79b58a8bb3c0f88ba.zip
media-video/videotrans: Depend on virtual/imagemagick-tools
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3907
Diffstat (limited to 'media-video/videotrans')
-rw-r--r--media-video/videotrans/videotrans-1.6.1-r1.ebuild22
-rw-r--r--media-video/videotrans/videotrans-1.6.1-r2.ebuild (renamed from media-video/videotrans/videotrans-1.6.1.ebuild)22
2 files changed, 22 insertions, 22 deletions
diff --git a/media-video/videotrans/videotrans-1.6.1-r1.ebuild b/media-video/videotrans/videotrans-1.6.1-r1.ebuild
index 7ed341220bf1..c451dcdb43d9 100644
--- a/media-video/videotrans/videotrans-1.6.1-r1.ebuild
+++ b/media-video/videotrans/videotrans-1.6.1-r1.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-inherit eutils
+EAPI=4
+
+inherit base eutils
DESCRIPTION="A package to convert movies to DVD format and to build DVDs with"
HOMEPAGE="http://videotrans.sourceforge.net/"
@@ -14,29 +15,22 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="libav"
+IUSE=""
-DEPEND="
+DEPEND="virtual/ffmpeg
media-video/mplayer
media-video/mjpegtools[png]
media-video/dvdauthor
- || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
- libav? ( media-video/libav )
- !libav? ( media-video/ffmpeg:0 )
-"
+ virtual/imagemagick-tools"
RDEPEND="${DEPEND}
www-client/lynx
app-shells/bash
- sys-devel/bc
-"
+ sys-devel/bc"
DOCS="aspects.txt CHANGES THANKS TODO"
src_prepare() {
# fixing LDFLAGS usage
sed -i -e 's|^\(LDFLAGS.*=\).*\( @LIBS@.*\)|\1\2 @LDFLAGS@|' src/Makefile.in
-
- # Debian patch to support libav
- use libav && epatch "${FILESDIR}"/${P}-libav.patch
}
diff --git a/media-video/videotrans/videotrans-1.6.1.ebuild b/media-video/videotrans/videotrans-1.6.1-r2.ebuild
index d1899a77b9fb..f8f75d374fbb 100644
--- a/media-video/videotrans/videotrans-1.6.1.ebuild
+++ b/media-video/videotrans/videotrans-1.6.1-r2.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
-
-inherit base eutils
+EAPI=5
+inherit eutils
DESCRIPTION="A package to convert movies to DVD format and to build DVDs with"
HOMEPAGE="http://videotrans.sourceforge.net/"
@@ -15,22 +14,29 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
+IUSE="libav"
-DEPEND="virtual/ffmpeg
+DEPEND="
media-video/mplayer
media-video/mjpegtools[png]
media-video/dvdauthor
- || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )"
+ virtual/imagemagick-tools
+ libav? ( media-video/libav )
+ !libav? ( media-video/ffmpeg:0 )
+"
RDEPEND="${DEPEND}
www-client/lynx
app-shells/bash
- sys-devel/bc"
+ sys-devel/bc
+"
DOCS="aspects.txt CHANGES THANKS TODO"
src_prepare() {
# fixing LDFLAGS usage
sed -i -e 's|^\(LDFLAGS.*=\).*\( @LIBS@.*\)|\1\2 @LDFLAGS@|' src/Makefile.in
+
+ # Debian patch to support libav
+ use libav && epatch "${FILESDIR}"/${P}-libav.patch
}