summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-06-19 09:42:41 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-06-19 09:43:39 +0300
commit91cbd1ef16421f8821e659517d1b4f4800b9f74b (patch)
tree3a4b38a5c4cc48a6fb1efc49cbb9391d7c8f77eb /media-video/yle-dl
parentsys-fs/lxcfs: bump to 4.0.4 (diff)
downloadgentoo-91cbd1ef16421f8821e659517d1b4f4800b9f74b.tar.gz
gentoo-91cbd1ef16421f8821e659517d1b4f4800b9f74b.tar.bz2
gentoo-91cbd1ef16421f8821e659517d1b4f4800b9f74b.zip
media-video/yle-dl: bump to 2020-06-18
- drop distutils single impl, - pycryptodome is not needed anymore. Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-video/yle-dl')
-rw-r--r--media-video/yle-dl/Manifest1
-rw-r--r--media-video/yle-dl/yle-dl-20200618.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/media-video/yle-dl/Manifest b/media-video/yle-dl/Manifest
index 2c58596e4f6b..8da5c32795cc 100644
--- a/media-video/yle-dl/Manifest
+++ b/media-video/yle-dl/Manifest
@@ -1 +1,2 @@
DIST yle-dl-20200419.tar.gz 87267 BLAKE2B 2637620758c1a083502eb9468bbe5e7353855051c3379d448f6a4b9adcf8113293e4a7a8887138df68fcfd16938ab3846034a8f57cb9d366467a22c23b53ebaa SHA512 3d064e080e0c9172e15134eaa179ae96240ed9fc74a7a8a9a9aa18049397e0fea62465f5768db488928f23af1fa1195d78a8a4a6bbafcab4bcda6d05cda70ccf
+DIST yle-dl-20200618.tar.gz 84932 BLAKE2B 686849db71eccbf94787bb913c41a43e65bd57b8acdec090af675ffd10dec3929f4d742d040b0e248606e086d76b7699fa11179e449811d36c821c9646e92dbb SHA512 21ffeec2939a10f48a83265df06769337bd78bc121e58f25e05e1607c93c9d2c07cb592fe934496db0f647f9e551bf903a3401a13a2f6708db3e3cb48eaa3260
diff --git a/media-video/yle-dl/yle-dl-20200618.ebuild b/media-video/yle-dl/yle-dl-20200618.ebuild
new file mode 100644
index 000000000000..bd1cb08e0904
--- /dev/null
+++ b/media-video/yle-dl/yle-dl-20200618.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Download media files from Yle Areena"
+HOMEPAGE="https://aajanki.github.io/yle-dl/ https://github.com/aajanki/yle-dl"
+SRC_URI="https://github.com/aajanki/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Requires an active internet connection during tests,
+# FEATURES="-network-sandbox" to test.
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ media-video/ffmpeg
+ net-misc/wget
+ >=dev-python/attrs-18.1.0[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.13.0[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mini-amf[${PYTHON_USEDEP}]
+ dev-python/progress[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]"
+DEPEND="test? (
+ ${RDEPEND}
+ media-video/ffmpeg[gnutls]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+BDEPEND="${PYTHON_DEPS}"
+
+distutils_enable_tests setup.py
+
+DOCS=( COPYING ChangeLog README.fi README.md yledl.conf.sample )
+
+src_install() {
+ docompress -x "/usr/share/doc/${PF}/yledl.conf.sample"
+ distutils-r1_src_install
+}
+
+pkg_postinst() {
+ elog "Sample configuration file has been installed to "
+ elog " /usr/share/doc/yle-dl-${PV}/yledl.conf.sample"
+ elog ""
+ elog "Optional download engines: "
+ optfeature "php download engine using rtmpdump" "dev-lang/php:*[bcmath,cli,curl,simplexml] media-video/rtmpdump"
+ optfeature "youtube-dl download engine" net-misc/youtube-dl
+}