summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-02-20 23:56:35 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-02-20 23:56:35 +0100
commit08d51a2428e8e9f44760a02f40a576a87a21af2a (patch)
tree2472d21a820b89847940333fa9e064e6412eb50b /media-video
parentnet-mail/fetchmail: 6.4.2 bump (diff)
downloadgentoo-08d51a2428e8e9f44760a02f40a576a87a21af2a.tar.gz
gentoo-08d51a2428e8e9f44760a02f40a576a87a21af2a.tar.bz2
gentoo-08d51a2428e8e9f44760a02f40a576a87a21af2a.zip
media-video/peek: 1.5.1 bump
Closes: https://bugs.gentoo.org/710168 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/peek/Manifest1
-rw-r--r--media-video/peek/files/peek-1.5.1-meson.patch79
-rw-r--r--media-video/peek/peek-1.5.1.ebuild54
3 files changed, 134 insertions, 0 deletions
diff --git a/media-video/peek/Manifest b/media-video/peek/Manifest
index b9947a3df0c8..992153c215aa 100644
--- a/media-video/peek/Manifest
+++ b/media-video/peek/Manifest
@@ -1 +1,2 @@
DIST peek-1.4.0.tar.gz 2647446 BLAKE2B 688acb01e127c31fd9d8c6713757bf01e6b4ed1211a32787f5729b6a26308599a61c4ab057a2a008d3cc388f9492a41e70c34c92e90ded0058bbb325e9f828c8 SHA512 ef1723f72d1c575493b2e9192cee6038807d37d875a797781169e5f4640635deda947362dcf2e1a9149fcfe88de532b8ea05c665b14b1befaa9aa8c982d9aa31
+DIST peek-1.5.1.tar.gz 2659772 BLAKE2B f33686bb023c5589cc61693854337b8ffda35da26ae8b0ea32ebb38d0738fc438424bae67d7eb600889ceb7377e8cc53eb9eaeef9f6bcf9d1a0d285265b4580b SHA512 dc25f24b1f5954ff26f399f86bf0a2a9b90c4d63c9cd33fcd44f16e447d23070c04e760c57bdc8a946e699c3038b8ee7afc44ce6daa7030e2f9e6f071be6eae4
diff --git a/media-video/peek/files/peek-1.5.1-meson.patch b/media-video/peek/files/peek-1.5.1-meson.patch
new file mode 100644
index 000000000000..4812fb621ddc
--- /dev/null
+++ b/media-video/peek/files/peek-1.5.1-meson.patch
@@ -0,0 +1,79 @@
+From 0851f6b41aec97e633743ffc2c552fc89597b532 Mon Sep 17 00:00:00 2001
+From: Bernard Cafarelli <bernard.cafarelli@gmail.com>
+Date: Tue, 24 Sep 2019 15:45:10 +0200
+Subject: [PATCH] Add meson build option for keybinder
+
+This uses the feature type from meson >=0.47 to force enable/disbable
+keybinder support (helpful for packaging)
+---
+ BUILD_NOTES.md | 2 +-
+ README.md | 2 +-
+ meson.build | 2 +-
+ meson_options.txt | 1 +
+ src/meson.build | 2 +-
+ 5 files changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/BUILD_NOTES.md b/BUILD_NOTES.md
+index c146cbc..2d8c8b2 100644
+--- a/BUILD_NOTES.md
++++ b/BUILD_NOTES.md
+@@ -34,7 +34,7 @@ From inside the Peek source folder run:
+ ### Debian package
+
+ #### Build requirements
+- - meson (>= 0.37.0)
++ - meson (>= 0.47.0)
+ - valac (>= 0.22)
+ - libgtk-3-dev (>= 3.20)
+ - libkeybinder-3.0-dev
+diff --git a/README.md b/README.md
+index 8a45e02..10c7e45 100644
+--- a/README.md
++++ b/README.md
+@@ -79,7 +79,7 @@ Support for more Wayland desktops might be added in the future (see FAQs below).
+ ### Development
+
+ - Vala compiler >= 0.22
+-- Meson >= 0.37.0
++- Meson >= 0.47.0
+ - Gettext (>= 0.19 for localized .desktop entry)
+ - txt2man (optional for building man page)
+
+diff --git a/meson.build b/meson.build
+index 2a2a2eb..88adc0c 100644
+--- a/meson.build
++++ b/meson.build
+@@ -1,6 +1,6 @@
+ project('peek', ['c', 'vala'],
+ version: '1.5.1',
+- meson_version: '>= 0.37.0',
++ meson_version: '>= 0.47.0',
+ )
+
+ add_project_arguments([
+diff --git a/meson_options.txt b/meson_options.txt
+index f88ceaa..526ccc9 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -1,4 +1,5 @@
+ option('build-tests', type : 'boolean', value : true)
++option('enable-keybinder', type : 'feature', value : 'auto')
+ option('enable-filechoosernative', type : 'boolean', value : false)
+ option('enable-gnome-shell', type : 'boolean', value : true)
+ option('enable-open-file-manager', type : 'boolean', value : true)
+diff --git a/src/meson.build b/src/meson.build
+index 455f3ba..406af03 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -49,7 +49,7 @@ enable_open_file_manager = get_option('enable-open-file-manager')
+
+ # Dependencies
+ gtk = dependency('gtk+-3.0', version: '>= 3.20')
+-keybinder = dependency('keybinder-3.0', required: false)
++keybinder = dependency('keybinder-3.0', required: get_option('enable-keybinder'))
+
+ peek_deps = [
+ dependency('cairo'),
+--
+2.25.1
+
diff --git a/media-video/peek/peek-1.5.1.ebuild b/media-video/peek/peek-1.5.1.ebuild
new file mode 100644
index 000000000000..3fbafaeb7dc3
--- /dev/null
+++ b/media-video/peek/peek-1.5.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.22"
+
+inherit gnome2-utils meson vala xdg
+
+DESCRIPTION="Simple animated Gif screen recorder"
+HOMEPAGE="https://github.com/phw/peek"
+SRC_URI="https://github.com/phw/peek/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="keybinder test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-libs/glib-2.38:2
+ media-video/ffmpeg[X,encode,vpx,xcb(+)]
+ virtual/imagemagick-tools
+ >=x11-libs/gtk+-3.20:3
+ keybinder? ( dev-libs/keybinder:3 )"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ app-text/txt2man
+ >=sys-devel/gettext-0.19
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-meson.patch )
+
+src_prepare() {
+ vala_src_prepare
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature keybinder enable-keybinder)
+ $(meson_use test build-tests)
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}