summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2021-05-06 00:31:44 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-05-06 11:46:42 +0300
commit124a95a62c264394f08d70dc0eb66db06b8c9d04 (patch)
treebbc178d275411ace916cc3db2e2802561dd74b40 /media-video
parentdev-python/towncrier: Mark ALLARCHES (diff)
downloadgentoo-124a95a62c264394f08d70dc0eb66db06b8c9d04.tar.gz
gentoo-124a95a62c264394f08d70dc0eb66db06b8c9d04.tar.bz2
gentoo-124a95a62c264394f08d70dc0eb66db06b8c9d04.zip
media-video/vdr: add gcc-11 compile fix
vdr defines std:: functions "min" "max" and "swap" as Template, which collides with gcc-11. Add a patch from upstream which fixes this, and fixes also compile problems with all media-video/vdr-* plugins using this functions, too Closes: https://bugs.gentoo.org/786882 Closes: https://bugs.gentoo.org/787389 Closes: https://bugs.gentoo.org/787236 Closes: https://bugs.gentoo.org/787140 Closes: https://bugs.gentoo.org/786801 Closes: https://bugs.gentoo.org/786795 Closes: https://bugs.gentoo.org/786672 Closes: https://bugs.gentoo.org/786285 Closes: https://bugs.gentoo.org/786258 Closes: https://bugs.gentoo.org/788583 Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/20695 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/vdr/files/vdr-2.2.0_gcc11.patch29
-rw-r--r--media-video/vdr/files/vdr-2.4.7_gcc11.patch314
-rw-r--r--media-video/vdr/vdr-2.2.0-r7.ebuild302
-rw-r--r--media-video/vdr/vdr-2.4.7-r1.ebuild (renamed from media-video/vdr/vdr-2.4.7.ebuild)8
4 files changed, 359 insertions, 294 deletions
diff --git a/media-video/vdr/files/vdr-2.2.0_gcc11.patch b/media-video/vdr/files/vdr-2.2.0_gcc11.patch
new file mode 100644
index 000000000000..297cdceabf56
--- /dev/null
+++ b/media-video/vdr/files/vdr-2.2.0_gcc11.patch
@@ -0,0 +1,29 @@
+Fix compile with gcc-11, officially from kls
+
+Signed-off-by: Martin Dummer <martin.dummer@gmx.net>
+
+--- a/tools.h 2021-05-05 21:48:32.382919856 +0200
++++ b/tools.h 2021-05-05 21:53:10.184522278 +0200
+@@ -50,7 +50,10 @@
+ #define CHECK(s) { if ((s) < 0) LOG_ERROR; } // used for 'ioctl()' calls
+ #define FATALERRNO (errno && errno != EAGAIN && errno != EINTR)
+
+-#ifndef __STL_CONFIG_H // in case some plugin needs to use the STL
++// In case some plugin needs to use the STL and gets an error message regarding one
++// of these functions, you can #define DISABLE_TEMPLATES_COLLIDING_WITH_STL before
++// including any VDR header files.
++#if !defined(DISABLE_TEMPLATES_COLLIDING_WITH_STL)
+ template<class T> inline T min(T a, T b) { return a <= b ? a : b; }
+ template<class T> inline T max(T a, T b) { return a >= b ? a : b; }
+ template<class T> inline int sgn(T a) { return a < 0 ? -1 : a > 0 ? 1 : 0; }
+--- a/recording.c 2021-05-05 22:08:23.898974097 +0200
++++ b/recording.c 2021-05-05 22:08:39.323280274 +0200
+@@ -2949,7 +2949,7 @@
+ }
+ // found a non existing file suffix
+ }
+- if (Open() >= 0) {
++ if (Open()) {
+ if (!record && Offset >= 0 && file && file->Seek(Offset, SEEK_SET) != Offset) {
+ LOG_ERROR_STR(fileName);
+ return NULL;
diff --git a/media-video/vdr/files/vdr-2.4.7_gcc11.patch b/media-video/vdr/files/vdr-2.4.7_gcc11.patch
index 866b018b5b79..1e37b2f0010c 100644
--- a/media-video/vdr/files/vdr-2.4.7_gcc11.patch
+++ b/media-video/vdr/files/vdr-2.4.7_gcc11.patch
@@ -1,292 +1,26 @@
-https://bugs.gentoo.org/786882
+Fix compile with gcc-11, officially from kls
-compile fix for gcc-11
+Signed-off-by: Martin Dummer <martin.dummer@gmx.net>
-Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org> (02 May 2021)
-diff -Naur vdr-2.4.7.orig/channels.c vdr-2.4.7/channels.c
---- vdr-2.4.7.orig/channels.c 2021-05-02 19:34:32.312653108 +0200
-+++ vdr-2.4.7/channels.c 2021-05-02 19:39:19.241653108 +0200
-@@ -11,6 +11,7 @@
- #include <ctype.h>
- #include "device.h"
- #include "libsi/si.h"
-+using namespace std;
-
- // IMPORTANT NOTE: in the 'sscanf()' calls there is a blank after the '%d'
- // format characters in order to allow any number of blanks after a numeric
-diff -Naur vdr-2.4.7.orig/ci.c vdr-2.4.7/ci.c
---- vdr-2.4.7.orig/ci.c 2021-05-02 19:34:32.313653108 +0200
-+++ vdr-2.4.7/ci.c 2021-05-02 19:49:53.216653108 +0200
-@@ -27,6 +27,8 @@
- #include "skins.h"
- #include "tools.h"
-
-+using namespace std;
-+
- // Set these to 'true' for debug output:
- static bool DumpTPDUDataTransfer = false;
- static bool DebugProtocol = false;
-diff -Naur vdr-2.4.7.orig/device.c vdr-2.4.7/device.c
---- vdr-2.4.7.orig/device.c 2021-05-02 19:34:32.313653108 +0200
-+++ vdr-2.4.7/device.c 2021-05-02 19:43:19.071653108 +0200
-@@ -20,6 +20,8 @@
- #include "status.h"
- #include "transfer.h"
-
-+using namespace std;
-+
- // --- cLiveSubtitle ---------------------------------------------------------
-
- class cLiveSubtitle : public cReceiver {
-diff -Naur vdr-2.4.7.orig/diseqc.c vdr-2.4.7/diseqc.c
---- vdr-2.4.7.orig/diseqc.c 2021-05-02 19:34:32.314653108 +0200
-+++ vdr-2.4.7/diseqc.c 2021-05-02 19:50:14.177653108 +0200
-@@ -14,6 +14,8 @@
- #include "sources.h"
- #include "thread.h"
-
-+using namespace std;
-+
- #define ALL_DEVICES (~0) // all bits set to '1'
- #define MAX_DEVICES 32 // each bit in a 32-bit integer represents one device
-
-diff -Naur vdr-2.4.7.orig/dvbdevice.c vdr-2.4.7/dvbdevice.c
---- vdr-2.4.7.orig/dvbdevice.c 2021-05-02 19:34:32.314653108 +0200
-+++ vdr-2.4.7/dvbdevice.c 2021-05-02 19:50:35.634653108 +0200
-@@ -21,6 +21,8 @@
- #include "menuitems.h"
- #include "sourceparams.h"
-
-+using namespace std;
-+
- static int DvbApiVersion = 0x0000; // the version of the DVB driver actually in use (will be determined by the first device created)
-
- #define DVBS_TUNE_TIMEOUT 9000 //ms
-diff -Naur vdr-2.4.7.orig/dvbplayer.c vdr-2.4.7/dvbplayer.c
---- vdr-2.4.7.orig/dvbplayer.c 2021-05-02 19:34:32.314653108 +0200
-+++ vdr-2.4.7/dvbplayer.c 2021-05-02 19:43:47.344653108 +0200
-@@ -15,6 +15,8 @@
- #include "thread.h"
- #include "tools.h"
-
-+using namespace std;
-+
- // --- cPtsIndex -------------------------------------------------------------
-
- #define PTSINDEX_ENTRIES 1024
-diff -Naur vdr-2.4.7.orig/dvbspu.c vdr-2.4.7/dvbspu.c
---- vdr-2.4.7.orig/dvbspu.c 2021-05-02 19:34:32.314653108 +0200
-+++ vdr-2.4.7/dvbspu.c 2021-05-02 19:44:08.952653108 +0200
-@@ -17,6 +17,8 @@
- #include <inttypes.h>
- #include <math.h>
-
-+using namespace std;
-+
- /*
- * cDvbSpubitmap:
- *
-diff -Naur vdr-2.4.7.orig/dvbsubtitle.c vdr-2.4.7/dvbsubtitle.c
---- vdr-2.4.7.orig/dvbsubtitle.c 2021-05-02 19:34:32.315653108 +0200
-+++ vdr-2.4.7/dvbsubtitle.c 2021-05-02 19:44:42.537653108 +0200
-@@ -16,6 +16,8 @@
- #include "device.h"
- #include "libsi/si.h"
-
-+using namespace std;
-+
- #define PAGE_COMPOSITION_SEGMENT 0x10
- #define REGION_COMPOSITION_SEGMENT 0x11
- #define CLUT_DEFINITION_SEGMENT 0x12
-diff -Naur vdr-2.4.7.orig/eit.c vdr-2.4.7/eit.c
---- vdr-2.4.7.orig/eit.c 2021-05-02 19:34:32.315653108 +0200
-+++ vdr-2.4.7/eit.c 2021-05-02 19:45:16.962653108 +0200
-@@ -18,6 +18,8 @@
- #include "libsi/section.h"
- #include "libsi/descriptor.h"
-
-+using namespace std;
-+
- #define VALID_TIME (31536000 * 2) // two years
-
- #define DBGEIT 0
-diff -Naur vdr-2.4.7.orig/font.c vdr-2.4.7/font.c
---- vdr-2.4.7.orig/font.c 2021-05-02 19:34:32.315653108 +0200
-+++ vdr-2.4.7/font.c 2021-05-02 19:51:53.540653108 +0200
-@@ -21,6 +21,8 @@
- #include "osd.h"
- #include "tools.h"
-
-+using namespace std;
-+
- const char *DefaultFontOsd = "Sans Serif:Bold";
- const char *DefaultFontSml = "Sans Serif";
- const char *DefaultFontFix = "Courier:Bold";
-diff -Naur vdr-2.4.7.orig/menu.c vdr-2.4.7/menu.c
---- vdr-2.4.7.orig/menu.c 2021-05-02 19:34:32.317653108 +0200
-+++ vdr-2.4.7/menu.c 2021-05-02 19:45:44.891653108 +0200
-@@ -33,6 +33,8 @@
- #include "transfer.h"
- #include "videodir.h"
-
-+using namespace std;
-+
- #define MAXWAIT4EPGINFO 3 // seconds
- #define MODETIMEOUT 3 // seconds
- #define NEWTIMERLIMIT 120 // seconds until the start time of a new timer created from the Schedule menu,
-diff -Naur vdr-2.4.7.orig/menuitems.c vdr-2.4.7/menuitems.c
---- vdr-2.4.7.orig/menuitems.c 2021-05-02 19:34:32.318653108 +0200
-+++ vdr-2.4.7/menuitems.c 2021-05-02 19:46:02.483653108 +0200
-@@ -17,6 +17,8 @@
- #include "skins.h"
- #include "status.h"
-
-+using namespace std;
-+
- #define AUTO_ADVANCE_TIMEOUT 1500 // ms before auto advance when entering characters via numeric keys
-
- const char *FileNameChars = trNOOP("FileNameChars$ abcdefghijklmnopqrstuvwxyz0123456789-.,#~\\^$[]|()*+?{}/:%@&");
-diff -Naur vdr-2.4.7.orig/mtd.c vdr-2.4.7/mtd.c
---- vdr-2.4.7.orig/mtd.c 2021-05-02 19:34:32.318653108 +0200
-+++ vdr-2.4.7/mtd.c 2021-05-02 19:46:23.355653108 +0200
-@@ -10,6 +10,8 @@
- #include "mtd.h"
- #include "receiver.h"
-
-+using namespace std;
-+
- //#define DEBUG_MTD
- #ifdef DEBUG_MTD
- #define DBGMTD(a...) dsyslog(a)
-diff -Naur vdr-2.4.7.orig/nit.c vdr-2.4.7/nit.c
---- vdr-2.4.7.orig/nit.c 2021-05-02 19:34:32.318653108 +0200
-+++ vdr-2.4.7/nit.c 2021-05-02 19:52:19.012653108 +0200
-@@ -16,6 +16,8 @@
- #include "libsi/descriptor.h"
- #include "tools.h"
-
-+using namespace std;
-+
- #define DVB_SYSTEM_1 0 // see also dvbdevice.c
- #define DVB_SYSTEM_2 1
-
-diff -Naur vdr-2.4.7.orig/osd.c vdr-2.4.7/osd.c
---- vdr-2.4.7.orig/osd.c 2021-05-02 19:34:32.318653108 +0200
-+++ vdr-2.4.7/osd.c 2021-05-02 19:47:12.501653108 +0200
-@@ -16,6 +16,8 @@
- #include "device.h"
- #include "tools.h"
-
-+using namespace std;
-+
- tColor HsvToColor(double H, double S, double V)
- {
- if (S > 0) {
-diff -Naur vdr-2.4.7.orig/osdbase.c vdr-2.4.7/osdbase.c
---- vdr-2.4.7.orig/osdbase.c 2021-05-02 19:34:32.318653108 +0200
-+++ vdr-2.4.7/osdbase.c 2021-05-02 19:46:53.516653108 +0200
-@@ -15,6 +15,8 @@
- #include "remote.h"
- #include "status.h"
-
-+using namespace std;
-+
- // --- cOsdItem --------------------------------------------------------------
-
- cOsdItem::cOsdItem(eOSState State)
-diff -Naur vdr-2.4.7.orig/recording.c vdr-2.4.7/recording.c
---- vdr-2.4.7.orig/recording.c 2021-05-02 19:34:32.323653108 +0200
-+++ vdr-2.4.7/recording.c 2021-05-02 19:47:45.990653108 +0200
-@@ -31,6 +31,8 @@
- #include "tools.h"
- #include "videodir.h"
-
-+using namespace std;
-+
- #define SUMMARYFALLBACK
-
- #define RECEXT ".rec"
-diff -Naur vdr-2.4.7.orig/remux.c vdr-2.4.7/remux.c
---- vdr-2.4.7.orig/remux.c 2021-05-02 19:34:32.323653108 +0200
-+++ vdr-2.4.7/remux.c 2021-05-02 19:48:03.230653108 +0200
-@@ -16,6 +16,8 @@
- #include "shutdown.h"
- #include "tools.h"
-
-+using namespace std;
-+
- // Set these to 'true' for debug output:
- static bool DebugPatPmt = false;
- static bool DebugFrames = false;
-diff -Naur vdr-2.4.7.orig/skinclassic.c vdr-2.4.7/skinclassic.c
---- vdr-2.4.7.orig/skinclassic.c 2021-05-02 19:34:32.324653108 +0200
-+++ vdr-2.4.7/skinclassic.c 2021-05-02 19:48:26.271653108 +0200
-@@ -14,6 +14,8 @@
- #include "themes.h"
- #include "videodir.h"
-
-+using namespace std;
-+
- #define ScrollWidth (Setup.FontOsdSize / 4)
- #define TextFrame (Setup.FontOsdSize / 10)
- #define TextSpacing (Setup.FontOsdSize / 4)
-diff -Naur vdr-2.4.7.orig/skinlcars.c vdr-2.4.7/skinlcars.c
---- vdr-2.4.7.orig/skinlcars.c 2021-05-02 19:34:32.324653108 +0200
-+++ vdr-2.4.7/skinlcars.c 2021-05-02 19:48:46.063653108 +0200
-@@ -63,6 +63,8 @@
- #include "symbols/teletext.xpm"
- #include "symbols/volume.xpm"
-
-+using namespace std;
-+
- #define Gap (Setup.FontOsdSize / 5 & ~1) // must be even
- #define TextFrame (Setup.FontOsdSize / TEXT_ALIGN_BORDER)
- #define TextSpacing (2 * TextFrame)
-diff -Naur vdr-2.4.7.orig/skinsttng.c vdr-2.4.7/skinsttng.c
---- vdr-2.4.7.orig/skinsttng.c 2021-05-02 19:34:32.324653108 +0200
-+++ vdr-2.4.7/skinsttng.c 2021-05-02 19:49:15.256653108 +0200
-@@ -50,6 +50,8 @@
- #include "symbols/teletext.xpm"
- #include "symbols/volume.xpm"
-
-+using namespace std;
-+
- #define Roundness (Setup.FontOsdSize / 2)
- #define Gap (Setup.FontOsdSize / 5)
- #define ScrollWidth (Setup.FontOsdSize / 4)
-diff -Naur vdr-2.4.7.orig/thread.c vdr-2.4.7/thread.c
---- vdr-2.4.7.orig/thread.c 2021-05-02 19:59:16.883653108 +0200
-+++ vdr-2.4.7/thread.c 2021-05-02 20:00:08.879653108 +0200
-@@ -24,6 +24,8 @@
- #include <unistd.h>
- #include "tools.h"
-
-+using namespace std;
-+
- #define ABORT { dsyslog("ABORT!"); cBackTrace::BackTrace(); abort(); }
-
- //#define DEBUG_LOCKING // uncomment this line to activate debug output for locking
-diff -Naur vdr-2.4.7.orig/timers.c vdr-2.4.7/timers.c
---- vdr-2.4.7.orig/timers.c 2021-05-02 19:59:16.883653108 +0200
-+++ vdr-2.4.7/timers.c 2021-05-02 19:59:52.287653108 +0200
-@@ -17,6 +17,8 @@
- #include "status.h"
- #include "svdrp.h"
-
-+using namespace std;
-+
- // IMPORTANT NOTE: in the 'sscanf()' calls there is a blank after the '%d'
- // format characters in order to allow any number of blanks after a numeric
- // value!
-diff -Naur vdr-2.4.7.orig/tools.c vdr-2.4.7/tools.c
---- vdr-2.4.7.orig/tools.c 2021-05-02 20:02:40.535653108 +0200
-+++ vdr-2.4.7/tools.c 2021-05-02 20:03:06.859653108 +0200
-@@ -28,6 +28,8 @@
- #include "i18n.h"
- #include "thread.h"
-
-+using namespace std;
-+
- int SysLogLevel = 3;
-
- #define MAXSYSLOGBUF 256
+--- a/tools.h 2021/01/19 20:38:28 5.3
++++ b/tools.h 2021/05/05 15:16:45
+@@ -53,17 +53,15 @@
+
+ // In case some plugin needs to use the STL and gets an error message regarding one
+ // of these functions, you can #define DISABLE_TEMPLATES_COLLIDING_WITH_STL before
+-// including tools.h.
+-#if !defined(__STL_CONFIG_H) // for old versions of the STL
+-#if !defined(DISABLE_TEMPLATES_COLLIDING_WITH_STL) && !defined(_STL_ALGOBASE_H)
++// including any VDR header files.
++#if !defined(DISABLE_TEMPLATES_COLLIDING_WITH_STL)
+ template<class T> inline T min(T a, T b) { return a <= b ? a : b; }
+ template<class T> inline T max(T a, T b) { return a >= b ? a : b; }
+ #endif
+ template<class T> inline int sgn(T a) { return a < 0 ? -1 : a > 0 ? 1 : 0; }
+-#if !defined(DISABLE_TEMPLATES_COLLIDING_WITH_STL) && !defined(_MOVE_H)
++#if !defined(DISABLE_TEMPLATES_COLLIDING_WITH_STL)
+ template<class T> inline void swap(T &a, T &b) { T t = a; a = b; b = t; }
+ #endif
+-#endif
+
+ template<class T> inline T constrain(T v, T l, T h) { return v < l ? l : v > h ? h : v; }
diff --git a/media-video/vdr/vdr-2.2.0-r7.ebuild b/media-video/vdr/vdr-2.2.0-r7.ebuild
new file mode 100644
index 000000000000..42c9e675b2b5
--- /dev/null
+++ b/media-video/vdr/vdr-2.2.0-r7.ebuild
@@ -0,0 +1,302 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic l10n toolchain-funcs
+
+# Switches supported by extensions-patch
+EXT_PATCH_FLAGS="alternatechannel graphtft naludump permashift pinplugin
+ mainmenuhooks menuorg menuselection resumereset ttxtsubs"
+
+# names of the use-flags
+EXT_PATCH_FLAGS_RENAMED=""
+
+# names ext-patch uses internally, here only used for maintainer checks
+EXT_PATCH_FLAGS_RENAMED_EXT_NAME="bidi no_kbd sdnotify"
+
+MY_PV="${PV%_p*}"
+MY_P="${PN}-${MY_PV}"
+S="${WORKDIR}/${MY_P}"
+
+EXT_P="extpng-${P}-gentoo-edition-v1"
+
+DESCRIPTION="Video Disk Recorder - turns a pc into a powerful set top box for DVB"
+HOMEPAGE="http://www.tvdr.de/"
+SRC_URI="ftp://ftp.tvdr.de/vdr/${MY_P}.tar.bz2
+ mirror://gentoo/${EXT_P}.patch.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE="bidi debug keyboard html systemd vanilla ${EXT_PATCH_FLAGS} ${EXT_PATCH_FLAGS_RENAMED}"
+
+COMMON_DEPEND="
+ virtual/jpeg:*
+ sys-libs/libcap
+ >=media-libs/fontconfig-2.4.2
+ >=media-libs/freetype-2"
+DEPEND="${COMMON_DEPEND}
+ >=virtual/linuxtv-dvb-headers-5.3"
+RDEPEND="${COMMON_DEPEND}
+ dev-lang/perl
+ >=media-tv/gentoo-vdr-scripts-2.7
+ media-fonts/corefonts
+ bidi? ( dev-libs/fribidi )
+ systemd? ( sys-apps/systemd )"
+BDEPEND="sys-devel/gettext"
+
+CONF_DIR="/etc/vdr"
+CAP_FILE="${S}/capabilities.sh"
+CAPS="# Capabilities of the vdr-executable for use by startscript etc."
+
+pkg_setup() {
+ use debug && append-flags -g
+
+ PLUGIN_LIBDIR="/usr/$(get_libdir)/vdr/plugins"
+
+ tc-export CC CXX AR
+}
+
+add_cap() {
+ local arg
+ for arg; do
+ CAPS="${CAPS}\n${arg}=1"
+ done
+}
+
+enable_patch() {
+ local arg ARG_UPPER
+ for arg; do
+ ARG_UPPER=$(echo $arg | tr '[:lower:]' '[:upper:]')
+ echo "${ARG_UPPER} = 1" >> Make.config || die "cannot write to Make.config"
+
+ # codesnippet to bring the extpng defines into the vdr.pc CXXFLAGS CFLAGS
+ echo "-DUSE_${ARG_UPPER}" >> "${T}"/defines.tmp || die "cannot write to defines.tmp"
+ cat "${T}"/defines.tmp | tr \\\012 ' ' > "${T}"/defines.IUSE || die "cannot write to defines.tmp"
+ export DEFINES_IUSE=$( cat ${T}/defines.IUSE )
+ done
+}
+
+extensions_add_make_conf() {
+ # copy all ifdef for extensions-patch to Make.config
+ sed -e '1,/need to touch the following:/d' \
+ -e '/need to touch the following/,/^$/d' \
+ Make.config.template >> Make.config || die "cannot write to Make.config"
+}
+
+extensions_all_defines() {
+ # extract all possible settings for extensions-patch
+ sed -e '/^#\?[A-Z].*= 1/!d' -e 's/^#\?//' -e 's/ .*//' \
+ Make.config.template \
+ | sort \
+ | tr '[:upper:]' '[:lower:]' || die "error in function extensions_all_defines"
+}
+
+lang_po() {
+ LING_PO=$( ls ${S}/po | sed -e "s:.po::g" | cut -d_ -f1 | tr \\\012 ' ' )
+}
+
+src_configure() {
+ # support languages, written from right to left
+ export "BIDI=$(usex bidi 1 0)"
+ # systemd notification support
+ export "SDNOTIFY=$(usex systemd 1 0)"
+ # with/without keyboard
+ export "USE_KBD=$(usex keyboard 1 0)"
+}
+
+src_prepare() {
+ # apply maintenance-patches
+ ebegin "Changing paths for gentoo"
+
+ local DVBDIR="/usr/include"
+ local i
+ for i in ${DVB_HEADER_PATH} /usr/include/v4l-dvb-hg /usr/include; do
+ [[ -d ${i} ]] || continue
+ if [[ -f ${i}/linux/dvb/dmx.h ]]; then
+ einfo "Found DVB header files in ${i}"
+ DVBDIR="${i}"
+ break
+ fi
+ done
+
+ # checking for s2api headers
+ local api_version
+ api_version=$(awk -F' ' '/define DVB_API_VERSION / {print $3}' "${DVBDIR}"/linux/dvb/version.h)
+ api_version=${api_version}*$(awk -F' ' '/define DVB_API_VERSION_MINOR / {print $3}' "${DVBDIR}"/linux/dvb/version.h)
+
+ if [[ ${api_version:-0} -lt 5*3 ]]; then
+ eerror "DVB header files do not contain s2api support or too old for ${P}"
+ eerror "You cannot compile VDR against old dvb-header"
+ die "DVB headers too old"
+ fi
+
+ cat > Make.config <<-EOT || die "cannot write to Make.config"
+ #
+ # Generated by ebuild ${PF}
+ #
+ PREFIX = /usr
+ DVBDIR = ${DVBDIR}
+ PLUGINLIBDIR = ${PLUGIN_LIBDIR}
+ CONFDIR = ${CONF_DIR}
+ VIDEODIR = /var/vdr/video
+ LOCDIR = \$(PREFIX)/share/locale
+ INCDIR = \$(PREFIX)/include
+
+ DEFINES += -DCONFDIR=\"\$(CONFDIR)\"
+ INCLUDES += -I\$(DVBDIR)
+
+ # >=vdr-1.7.36-r1; parameter only used for compiletime on vdr
+ # PLUGINLIBDIR (plugin Makefile old) = LIBDIR (plugin Makefile new)
+ LIBDIR = ${PLUGIN_LIBDIR}
+ PCDIR = /usr/$(get_libdir)/pkgconfig
+
+ EOT
+ eend 0
+
+ # wrt bug 586070
+ if has_version ">=sys-apps/systemd-230"; then
+ sed -e "s:libsystemd-daemon:libsystemd:g" -i Makefile || die "sed libsystemd failed"
+ fi
+
+ if ! use vanilla; then
+
+ # Now apply extensions patch
+ eapply "${WORKDIR}/${EXT_P}.patch"
+ sed -e 's/PERMASHIFT_V1/PERMASHIFT/g' -i "${S}"/*.[ch] "${S}"/Make.config* || die "sed failed"
+
+ # This allows us to start even if some plugin does not exist
+ # or is not loadable.
+ enable_patch PLUGINMISSING
+
+ if [[ -n ${VDR_MAINTAINER_MODE} ]]; then
+ einfo "Doing maintainer checks:"
+
+ # we do not support these patches
+ # (or have them already hard enabled)
+ local IGNORE_PATCHES="pluginmissing"
+
+ extensions_all_defines > "${T}"/new.IUSE || die "cannot write to new.IUSE"
+ echo $EXT_PATCH_FLAGS $EXT_PATCH_FLAGS_RENAMED_EXT_NAME \
+ $IGNORE_PATCHES | \
+ tr ' ' '\n' |sort > "${T}"/old.IUSE || die "cannot write to old.IUSE"
+ local DIFFS=$(diff -u "${T}"/old.IUSE "${T}"/new.IUSE|grep '^[+-][^+-]')
+ if [[ -z ${DIFFS} ]]; then
+ einfo "EXT_PATCH_FLAGS are up to date."
+ else
+ ewarn "IUSE differences!"
+ local diff
+ for diff in $DIFFS; do
+ ewarn "$diff"
+ done
+ fi
+ fi
+
+ ebegin "Enabling selected patches"
+ local flag
+ for flag in $EXT_PATCH_FLAGS; do
+ use $flag && enable_patch ${flag}
+ done
+
+ eend 0
+
+ extensions_add_make_conf
+
+ # add defined use-flags compile options to vdr.pc
+ sed -e "s:\$(CDEFINES) \$(CINCLUDES) \$(HDRDIR):\$(CDEFINES) \$(CINCLUDES) \$(HDRDIR) \$(DEFINES_IUSE):" \
+ -i Makefile || die "sed fails on Makefile"
+
+ ebegin "Make depend"
+ emake .dependencies >/dev/null
+ eend $? "make depend failed"
+
+ eapply "${FILESDIR}/${P}_gcc7extpng.patch"
+ eapply "${FILESDIR}/${P}_gcc11.patch"
+ fi
+
+ eapply "${FILESDIR}/${P}_gentoo.patch"
+ eapply "${FILESDIR}/${P}_unsignedtosigned.patch"
+ eapply "${FILESDIR}/${P}_glibc-2.24.patch"
+ eapply "${FILESDIR}/${P}-jpeg-9c.patch"
+ eapply "${FILESDIR}/${P}_glibc-2.31.patch"
+
+ # fix some makefile issues
+ sed -e "s:ifndef NO_KBD:ifeq (\$(USE_KBD),1):" \
+ -e "s:ifdef BIDI:ifeq (\$(BIDI),1):" \
+ -e "s:ifdef SDNOTIFY:ifeq (\$(SDNOTIFY),1):" \
+ -i "${S}"/Makefile || die "sed fails on Makefile"
+
+ eapply_user
+
+ add_cap CAP_UTF8
+
+ add_cap CAP_IRCTRL_RUNTIME_PARAM \
+ CAP_VFAT_RUNTIME_PARAM \
+ CAP_CHUID \
+ CAP_SHUTDOWN_AUTO_RETRY
+
+ echo -e ${CAPS} > "${CAP_FILE}"
+
+ # LINGUAS support
+ einfo "\n \t VDR supports the LINGUAS values"
+
+ lang_po
+
+ einfo "\t Please set one of this values in your sytem make.conf"
+ einfo "\t LINGUAS=\"${LING_PO}\"\n"
+
+ if [[ -z ${LINGUAS} ]]; then
+ einfo "\n \t No values in LINGUAS="
+ einfo "\t You will get only english text on OSD \n"
+ fi
+
+ strip-linguas ${LING_PO} en
+}
+
+src_install() {
+ # trick makefile not to create a videodir by supplying it with an existing
+ # directory
+ emake install \
+ VIDEODIR="/" \
+ DESTDIR="${ED}" install
+
+ keepdir "${PLUGIN_LIBDIR}"
+
+ # backup for plugins they don't be able to create this dir
+ keepdir "${CONF_DIR}"/plugins
+
+ if use html; then
+ local HTML_DOCS=( *.html )
+ fi
+
+ local DOCS=( MANUAL INSTALL README* HISTORY CONTRIBUTORS )
+
+ einstalldocs
+
+ insinto /usr/share/vdr
+ doins "${CAP_FILE}"
+
+ if use alternatechannel; then
+ insinto /etc/vdr
+ doins "${FILESDIR}"/channel_alternative.conf
+ fi
+
+ chown -R vdr:vdr "${ED}/${CONF_DIR}" || die "chown failed"
+}
+
+pkg_postinst() {
+
+ elog "\n\t---- 15 YEARS ANNIVERSARY EDITON ----\n"
+ elog "\tA lot of thanks to Klaus Schmidinger"
+ elog "\tfor this nice piece of Software...\n"
+
+ elog "It is a good idea to run vdrplugin-rebuild now."
+
+ elog "To get nice symbols in OSD we recommend to install"
+ elog "\t1. emerge media-fonts/vdrsymbols-ttf"
+ elog "\t2. select font VDRSymbolsSans in Setup"
+ elog ""
+ elog "To get an idea how to proceed now, have a look at our vdr-guide:"
+ elog "\thttps://wiki.gentoo.org/wiki/VDR"
+}
diff --git a/media-video/vdr/vdr-2.4.7.ebuild b/media-video/vdr/vdr-2.4.7-r1.ebuild
index c1f9413c3022..8fda32ee217b 100644
--- a/media-video/vdr/vdr-2.4.7.ebuild
+++ b/media-video/vdr/vdr-2.4.7-r1.ebuild
@@ -10,10 +10,10 @@ HOMEPAGE="http://www.tvdr.de/"
SRC_URI="http://git.tvdr.de/?p=vdr.git;a=snapshot;h=refs/tags/2.4.7;sf=tbz2 -> ${P}.tbz2
mainmenuhooks? ( http://vdr.websitec.de/download/${PN}/${PN}-2.4.1/${PN}-2.4.1_mainmenuhook-1.0.1.patch.bz2 )
menuorg? ( https://projects.vdr-developer.org/projects/plg-menuorg/repository/revisions/master/raw/vdr-patch/vdr-menuorg-2.3.x.diff )
- naludump? ( http://www.udo-richter.de/vdr/files/vdr-2.1.5-naludump-0.1.diff )
- pinplugin? ( http://vdr.websitec.de/download/${PN}/${P}/${PN}-2.4.6_pinplugin.patch.bz2 )
- ttxtsubs? ( http://vdr.websitec.de/download/${PN}/${P}/${PN}-2.4.6_ttxtsubs_v2.patch.bz2 )
- permashift? ( http://vdr.websitec.de/download/${PN}/${P}/vdr-2.4-patch-for-permashift.diff.bz2 )"
+ naludump? ( https://www.udo-richter.de/vdr/files/vdr-2.1.5-naludump-0.1.diff )
+ pinplugin? ( http://vdr.websitec.de/download/${PN}/vdr-2.4.6/${PN}-2.4.6_pinplugin.patch.bz2 )
+ ttxtsubs? ( http://vdr.websitec.de/download/${PN}/vdr-2.4.6/${PN}-2.4.6_ttxtsubs_v2.patch.bz2 )
+ permashift? ( http://vdr.websitec.de/download/${PN}/vdr-2.4.6/vdr-2.4-patch-for-permashift.diff.bz2 )"
LICENSE="GPL-2+"
SLOT="0"