summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-02-09 01:13:41 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-02-09 01:13:49 +0100
commit3a0e95b1a7161e311804cf13ecfdeb40a1528e56 (patch)
treeccbb2227e191477360b81b8a1735e6ad5843ddea /media-video
parentdev-python/python-debian: Add ~arm keyword (diff)
downloadgentoo-3a0e95b1a7161e311804cf13ecfdeb40a1528e56.tar.gz
gentoo-3a0e95b1a7161e311804cf13ecfdeb40a1528e56.tar.bz2
gentoo-3a0e95b1a7161e311804cf13ecfdeb40a1528e56.zip
media-video/pipewire: bump to v0.3.21
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/pipewire/Manifest1
-rw-r--r--media-video/pipewire/pipewire-0.3.21.ebuild136
2 files changed, 137 insertions, 0 deletions
diff --git a/media-video/pipewire/Manifest b/media-video/pipewire/Manifest
index 5c3c35032e2c..0c830a7b2b41 100644
--- a/media-video/pipewire/Manifest
+++ b/media-video/pipewire/Manifest
@@ -1,2 +1,3 @@
DIST pipewire-0.3.18.tar.gz 1277055 BLAKE2B 4a18bd668afaf144d6e83590293a744b6d2c2a7d8e9fc6ab581f22d294fac5a4841098875f8569f36b794c083e4ec9f0b7d4e29a10dc79286a4843996f7fb64e SHA512 933b15908e30c389555dd9f82f87c2e571b4cb078bfbe5ed1858440166093cdee2b1c15da50bc5ab36087b62e216786b95c2aad9403e5047ae33e4fe8a6f4cc5
DIST pipewire-0.3.20.tar.gz 1228482 BLAKE2B d5c51a7da984b075d4fd2504ecc2082527807a6319a42c44b09a687112c2ba10746a2554997e8f6fa36a06cdf5b94b4099adb1f8ee986673855db6e8e0356468 SHA512 7838cafe413e5082146e39a8d2cd29ec5193da68fa76c4d2b9390cbdf06d388c5a8b76f90fadf5f7ece4a8b1b86c3765b3fa968479f3bb9e11e84be006276c1c
+DIST pipewire-0.3.21.tar.gz 1243935 BLAKE2B b736a0253e8c0af96f7bdc47684d52bc8e70d4b2310b80a1b036ae3ef30fd042e1ad641aae342f9727b3191a38cfd36794879bf54954124b99984e2841aa7373 SHA512 cd1e7696c5712dfbd0f5ebffbb74f23ce5f6752744b062741546d55d524a4dca43776e1862fdc55faf5220c23f7ef9e0c5f9c3b1892a6b43ad50dfb99b9a66cc
diff --git a/media-video/pipewire/pipewire-0.3.21.ebuild b/media-video/pipewire/pipewire-0.3.21.ebuild
new file mode 100644
index 000000000000..c5f8c1bd95ad
--- /dev/null
+++ b/media-video/pipewire/pipewire-0.3.21.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/PipeWire/pipewire.git"
+ EGIT_BRANCH="work"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/PipeWire/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Multimedia processing graphs"
+HOMEPAGE="https://pipewire.org/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/0.3"
+IUSE="bluetooth debug doc ffmpeg gstreamer jack pulseaudio systemd test vulkan X"
+
+BDEPEND="
+ app-doc/xmltoman
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+"
+RDEPEND="
+ >=media-libs/alsa-lib-1.1.7
+ media-libs/libsdl2
+ >=media-libs/libsndfile-1.0.20
+ sys-apps/dbus
+ virtual/libudev
+ bluetooth? (
+ media-libs/sbc
+ net-wireless/bluez:=
+ )
+ ffmpeg? ( media-video/ffmpeg:= )
+ gstreamer? (
+ >=dev-libs/glib-2.32.0:2
+ >=media-libs/gstreamer-1.10.0:1.0
+ media-libs/gst-plugins-base:1.0
+ )
+ jack? ( >=media-sound/jack2-1.9.10:2 )
+ pulseaudio? (
+ dev-libs/glib:2
+ >=media-sound/pulseaudio-11.1
+ )
+ systemd? ( sys-apps/systemd )
+ vulkan? ( media-libs/vulkan-loader )
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ vulkan? ( dev-util/vulkan-headers )
+"
+
+DOCS=( {README,INSTALL}.md NEWS )
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ spa_use() {
+ if ! in_iuse ${1} || ! use ${1}; then
+ sed -e "/^add-spa-lib.*${1}/s/^/#${2-$1}-disabled-by-USE-no-${1}\:/" \
+ -e "/^load-module.*${1}/s/^/#${2-$1}-disabled-by-USE-no-${1}\:/" \
+ -i src/daemon/pipewire.conf.in || die
+ fi
+ }
+
+ default
+ spa_use libcamera
+ spa_use rtkit
+ spa_use bluetooth bluez5
+ spa_use jack
+ spa_use vulkan
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dexamples=true # contains required pipewire-media-session
+ -Dman=true
+ -Dspa-plugins=true
+ --buildtype=$(usex debug debugoptimized plain)
+ # alsa plugin and jack/pulseaudio emulation
+ -Dpipewire-alsa=true
+ $(meson_use jack pipewire-jack)
+ $(meson_use pulseaudio pipewire-pulseaudio)
+ # spa-plugins
+ # we install alsa support unconditionally
+ $(meson_use bluetooth bluez5)
+ $(meson_use ffmpeg)
+ $(meson_use jack)
+ $(meson_use vulkan)
+ # libcamera is not packaged
+ # misc
+ $(meson_use doc docs)
+ $(meson_use gstreamer)
+ $(meson_use gstreamer gstreamer-device-provider)
+ $(meson_use systemd)
+ $(meson_use test test)
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ dosym ../../../usr/share/alsa/alsa.conf.d/50-pipewire.conf /etc/alsa/conf.d/50-pipewire.conf
+
+# # TODO: this breaks alsa users
+# if use alsa; then
+# dosym ../../../usr/share/alsa/alsa.conf.d/99-pipewire-default.conf /etc/alsa/conf.d/99-pipewire-default.conf
+# fi
+}
+
+pkg_postinst() {
+ elog "Package has optional sys-auth/rtkit RUNTIME support that may be disabled"
+ elog "by setting DISABLE_RTKIT env var."
+ elog "To enable rtkit, uncomment the load-module line in /etc/pipewire/pipewire.conf"
+ elog
+ if use jack; then
+ elog "Please note that even though the libraries for JACK emulation have"
+ elog "been installed, this ebuild is not yet wired up to replace a JACK server."
+ elog
+ fi
+ if use pulseaudio; then
+ elog "Please note that even though the libraries for PulseAudio emulation have"
+ elog "been installed, this ebuild is not yet wired up to replace PulseAudio."
+ elog
+ fi
+ elog "Read INSTALL.md for information about ALSA plugin or JACK/PulseAudio emulation."
+}