summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-12-12 22:08:16 +0100
committerDavid Seifert <soap@gentoo.org>2016-12-12 22:10:26 +0100
commit3d76ab2d63e012a86b97cca52ec090a0ff656d4d (patch)
treed948b20f73c3f02216e779e6d95b316964dbc6fd /media-video
parentdev-php/pecl-memcached: fix typo "targest" -> "targets". (diff)
downloadgentoo-3d76ab2d63e012a86b97cca52ec090a0ff656d4d.tar.gz
gentoo-3d76ab2d63e012a86b97cca52ec090a0ff656d4d.tar.bz2
gentoo-3d76ab2d63e012a86b97cca52ec090a0ff656d4d.zip
media-video/motiontrack: Fix building with GCC 5
Gentoo-bug: 570352 * EAPI=6 * Simplify RDEPEND Package-Manager: portage-2.3.3
Diffstat (limited to 'media-video')
-rw-r--r--media-video/motiontrack/motiontrack-0.1.3-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-video/motiontrack/motiontrack-0.1.3-r1.ebuild b/media-video/motiontrack/motiontrack-0.1.3-r1.ebuild
new file mode 100644
index 000000000000..0deb13c564fc
--- /dev/null
+++ b/media-video/motiontrack/motiontrack-0.1.3-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="A set of tools that detect motion between two images"
+SRC_URI="http://gemia.de/motion/${P}.tar.gz"
+HOMEPAGE="http://motiontrack.sourceforge.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~ppc64 ~sparc ~mips ~alpha ~hppa ~amd64"
+
+IUSE="debug imagemagick multiprocess"
+
+RDEPEND="
+ imagemagick? ( media-gfx/imagemagick )
+ !imagemagick? ( media-libs/gd )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # fix missing inline definition
+ # with GCC 5, bug 570352
+ append-cflags -std=gnu89
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable !imagemagick gd) \
+ $(use_enable imagemagick magick) \
+ $(use_enable multiprocess cluster)
+}
+
+src_install() {
+ default
+ dodoc src/TheCode.txt
+}