summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-04-28 16:50:53 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-04-28 16:51:42 +0300
commit44cff5c30f141b7e1e656e68a4eb03c5257c9008 (patch)
treefa313634ea676a5a3ea0bc9b2b50b97b92ee0379 /media-video
parentdev-libs/libvoikko: enable python3.8 (diff)
downloadgentoo-44cff5c30f141b7e1e656e68a4eb03c5257c9008.tar.gz
gentoo-44cff5c30f141b7e1e656e68a4eb03c5257c9008.tar.bz2
gentoo-44cff5c30f141b7e1e656e68a4eb03c5257c9008.zip
media-video/vcsi: enable python3.8, EAPI-7
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/vcsi/vcsi-7-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-video/vcsi/vcsi-7-r1.ebuild b/media-video/vcsi/vcsi-7-r1.ebuild
new file mode 100644
index 000000000000..d659df03186c
--- /dev/null
+++ b/media-video/vcsi/vcsi-7-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Create thumbnail sheets from video files"
+HOMEPAGE="https://github.com/amietn/vcsi"
+SRC_URI="https://github.com/amietn/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/parsedatetime[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/texttable[${PYTHON_USEDEP}]
+ media-fonts/dejavu
+ media-video/ffmpeg"
+
+distutils_enable_tests nose