summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2021-03-22 11:06:25 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-22 11:06:25 +0100
commit4e7e25bb617a8202fb1a0f0381949dcd380de614 (patch)
tree1a1864944ebb9c00f6f2931744aa76c6000a4d6a /media-video
parentdev-libs/icu: work around cross-endian tests failing (diff)
downloadgentoo-4e7e25bb617a8202fb1a0f0381949dcd380de614.tar.gz
gentoo-4e7e25bb617a8202fb1a0f0381949dcd380de614.tar.bz2
gentoo-4e7e25bb617a8202fb1a0f0381949dcd380de614.zip
media-video/ffmpeg: work around cross-endian tests failing
Cross-compiling with LTO prevents the build system from detecting endianness. Upstream says that enabling LTO with CFLAGS is not supported, so filter -flto* out of CFLAGS after adding --enable-lto to the configure command (which just adds back -flto after endian tests pass). Closes: https://bugs.gentoo.org/754654 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ffmpeg-4.3.2.ebuild3
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild5
2 files changed, 5 insertions, 3 deletions
diff --git a/media-video/ffmpeg/ffmpeg-4.3.2.ebuild b/media-video/ffmpeg/ffmpeg-4.3.2.ebuild
index 565891baca14..1b5fccb1230b 100644
--- a/media-video/ffmpeg/ffmpeg-4.3.2.ebuild
+++ b/media-video/ffmpeg/ffmpeg-4.3.2.ebuild
@@ -424,8 +424,9 @@ multilib_src_configure() {
break
done
- # LTO support, bug #566282
+ # LTO support, bug #566282, bug #754654
is-flagq "-flto*" && myconf+=( "--enable-lto" )
+ filter-flags "-flto*"
# Mandatory configuration
myconf=(
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 2e4b8b8f43c8..8f00858f69a8 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -422,8 +422,9 @@ multilib_src_configure() {
break
done
- # LTO support, bug #566282
+ # LTO support, bug #566282, bug #754654
is-flagq "-flto*" && myconf+=( "--enable-lto" )
+ filter-flags "-flto*"
# Mandatory configuration
myconf=(