summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-02 01:59:33 +0100
committerSam James <sam@gentoo.org>2022-09-02 02:07:10 +0100
commit68ca288e4d62bdf7631746b20d40a72e2b6ba746 (patch)
tree85cd2efe1c57b80b1bf04b740b650682fd8ff400 /media-video
parentapp-admin/ansible-lint: add 6.5.2, drop 6.5.1 (diff)
downloadgentoo-68ca288e4d62bdf7631746b20d40a72e2b6ba746.tar.gz
gentoo-68ca288e4d62bdf7631746b20d40a72e2b6ba746.tar.bz2
gentoo-68ca288e4d62bdf7631746b20d40a72e2b6ba746.zip
media-video/bino: fix musl build w/ gcc-12
Closes: https://bugs.gentoo.org/866290 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/bino/bino-1.6.8.ebuild4
-rw-r--r--media-video/bino/files/bino-1.6.8-time-include.patch24
2 files changed, 28 insertions, 0 deletions
diff --git a/media-video/bino/bino-1.6.8.ebuild b/media-video/bino/bino-1.6.8.ebuild
index 0cdd8ab1a37c..f0f6a54eb8d1 100644
--- a/media-video/bino/bino-1.6.8.ebuild
+++ b/media-video/bino/bino-1.6.8.ebuild
@@ -30,6 +30,10 @@ DEPEND="${RDEPEND}"
BDEPEND="sys-devel/gettext
virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.8-time-include.patch
+)
+
src_configure() {
if use video_cards_nvidia; then
append-cppflags "-I${ESYSROOT}/usr/include/NVCtrl"
diff --git a/media-video/bino/files/bino-1.6.8-time-include.patch b/media-video/bino/files/bino-1.6.8-time-include.patch
new file mode 100644
index 000000000000..b10f42b1a40f
--- /dev/null
+++ b/media-video/bino/files/bino-1.6.8-time-include.patch
@@ -0,0 +1,24 @@
+Sent upstream by email on 2022-09-02.
+
+From 242b5df7074739fb4c74e2682cb9f325a5269c94 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Fri, 2 Sep 2022 02:04:26 +0100
+Subject: [PATCH 2/2] Fix build with GCC 12 and musl (missing <ctime> include)
+
+Fixes build errors like:
+```
+../../src/base/str.h:146:30: error: 'time_t' was not declared in this scope
+ 146 | std::string rfc2822_time(time_t t);
+```
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/src/base/str.h
++++ b/src/base/str.h
+@@ -31,6 +31,7 @@
+ #include <vector>
+ #include <cstdarg>
+ #include <cerrno>
++#include <ctime>
+
+ #ifdef __GNUC__
+ # define STR_AFP(a, b) __attribute__ ((format (printf, a, b)))