summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2019-10-27 14:40:29 +0100
committerSebastian Pipping <sping@gentoo.org>2019-10-27 14:41:01 +0100
commit7be43254287e718aaf5d6ed6fe220589dcf23dbd (patch)
tree11d9a140fc26367caedfede12b84ae65439f5ddc /media-video
parentdev-util/vulkan-headers: Add blockers until we can stabilize new deps (diff)
downloadgentoo-7be43254287e718aaf5d6ed6fe220589dcf23dbd.tar.gz
gentoo-7be43254287e718aaf5d6ed6fe220589dcf23dbd.tar.bz2
gentoo-7be43254287e718aaf5d6ed6fe220589dcf23dbd.zip
media-video/vamps: EAPI 7
Bug: https://bugs.gentoo.org/697264 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.78, Repoman-2.3.16
Diffstat (limited to 'media-video')
-rw-r--r--media-video/vamps/vamps-0.99.2-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-video/vamps/vamps-0.99.2-r2.ebuild b/media-video/vamps/vamps-0.99.2-r2.ebuild
new file mode 100644
index 000000000000..7167705a559c
--- /dev/null
+++ b/media-video/vamps/vamps-0.99.2-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Very fast requantisizing tool for backup DVDs"
+HOMEPAGE="http://vamps.sourceforge.net/"
+SRC_URI="mirror://sourceforge/vamps/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/libdvdread-0.9.4"
+RDEPEND="${DEPEND}
+ >=media-video/dvdauthor-0.6.10"
+
+PATCHES=(
+ "${FILESDIR}/${P}-premature-eof.patch"
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin vamps/vamps play_cell/play_cell
+}