summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gmail.com>2019-07-29 22:20:14 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-07-30 02:22:55 +0300
commit81754ad34e9ffce5d722cb31d33690bb6d76d0c2 (patch)
tree4a582da378b57bf6753fd12bfef41db46ff637b0 /media-video
parentx11-terms/terminology: update maintainer info (diff)
downloadgentoo-81754ad34e9ffce5d722cb31d33690bb6d76d0c2.tar.gz
gentoo-81754ad34e9ffce5d722cb31d33690bb6d76d0c2.tar.bz2
gentoo-81754ad34e9ffce5d722cb31d33690bb6d76d0c2.zip
media-video/photofilmstrip: bump to 3.7.1
Closes: https://bugs.gentoo.org/643324 Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Joonas Niilola <juippis@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/12574 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/photofilmstrip/Manifest1
-rw-r--r--media-video/photofilmstrip/files/photofilmstrip-3.7.1-disable-docs-by-default.patch15
-rw-r--r--media-video/photofilmstrip/photofilmstrip-3.7.1.ebuild67
3 files changed, 83 insertions, 0 deletions
diff --git a/media-video/photofilmstrip/Manifest b/media-video/photofilmstrip/Manifest
index 81e3b4862c35..4773f1262006 100644
--- a/media-video/photofilmstrip/Manifest
+++ b/media-video/photofilmstrip/Manifest
@@ -1 +1,2 @@
DIST photofilmstrip-2.1.0.tar.gz 243163 BLAKE2B 30bc0de885a00b715377b262039b3c22425315e77c7e5ac7db377535f0dc3a7614bd83b894bcfbaf53601be140fef0e9754a3911958b9f71aec1e5d0214fe972 SHA512 e3cbf19d73d6cc16dcef23c11d84e5bfd1d0721cb72bb4d775390152be2fb20cab14912a9e0e73ef2d9dba9c041883591df2708cdeb7e7447cbcb18e750ea142
+DIST photofilmstrip-3.7.1.tar.gz 354585 BLAKE2B df1e8756677814f35a59d7f4d3585647393e37262eb80c3299805cb0811cdfb4a16c96f90aaa192469266805145db68a582671a34f2b2780b75f1e0318460bd7 SHA512 fc2284c6c52eea5d9a6415149681e26505d6e084ad31897c44cde8e2b4845584b8521b375da06fd0a59179bfa73f6aabe769caad7a8186d5f87ecacebaff24fb
diff --git a/media-video/photofilmstrip/files/photofilmstrip-3.7.1-disable-docs-by-default.patch b/media-video/photofilmstrip/files/photofilmstrip-3.7.1-disable-docs-by-default.patch
new file mode 100644
index 000000000000..78dd6697ca72
--- /dev/null
+++ b/media-video/photofilmstrip/files/photofilmstrip-3.7.1-disable-docs-by-default.patch
@@ -0,0 +1,15 @@
+diff -Naur a/setup.py b/setup.py
+--- a/setup.py 2019-07-29 20:46:23.212292642 +0300
++++ b/setup.py 2019-07-29 20:47:47.426300796 +0300
+@@ -20,10 +20,7 @@
+ from distutils.dir_util import remove_tree
+ from distutils.sysconfig import get_python_lib
+
+-try:
+- from sphinx.application import Sphinx
+-except ImportError:
+- Sphinx = None
++Sphinx = None
+
+ try:
+ import py2exe
diff --git a/media-video/photofilmstrip/photofilmstrip-3.7.1.ebuild b/media-video/photofilmstrip/photofilmstrip-3.7.1.ebuild
new file mode 100644
index 000000000000..a8f65086077e
--- /dev/null
+++ b/media-video/photofilmstrip/photofilmstrip-3.7.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 eutils xdg-utils
+
+DESCRIPTION="Movie slideshow creator using Ken Burns effect"
+HOMEPAGE="https://www.photofilmstrip.org/en/ https://github.com/PhotoFilmStrip"
+SRC_URI="https://github.com/PhotoFilmStrip/PFS/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/gst-python[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/wxpython:4.0[${PYTHON_USEDEP}]
+ media-plugins/gst-plugins-jpeg:1.0
+ x11-libs/wxGTK:*[X]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}/${P}-disable-docs-by-default.patch" )
+
+src_prepare() {
+ default
+
+ # fix 'unexpected path' QA warning on einstalldocs
+ sed -i 's|"share", "doc", "photofilmstrip"|"share", "doc", "'${PF}'"|g' setup.py ||
+ die "Fixing unexpected path failed."
+
+ # build html docs
+ if use doc; then
+ sed -i 's/Sphinx = None/from sphinx.application import Sphinx/g' -i setup.py ||
+ die "Failed to enable building docs with sphinx."
+ fi
+
+ # fix a QA issue with .desktop file
+ sed -i '/Version=/d' data/photofilmstrip.desktop || die "Failed to update .desktop file."
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ doman docs/manpage/*.1
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+
+ optfeature "additional rendering formats" media-plugins/gst-plugins-bad
+ optfeature "additional rendering formats" media-plugins/gst-plugins-good
+ optfeature "additional rendering formats" media-plugins/gst-plugins-ugly
+ optfeature "ogg/theora support" media-libs/gst-plugins-base[theora]
+ optfeature "h264 (MKV/MP4) support" media-plugins/gst-plugins-x264
+ optfeature "h265 (MKV) support" media-plugins/gst-plugins-x265
+ optfeature "MPEG 1/2 (DVD) support" media-plugins/gst-plugins-mpeg2enc
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}