summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-10-16 12:08:44 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-10-16 12:09:10 +0200
commit932d92b665e50803ed71bc846da723af547c2e49 (patch)
tree1fd7813cf8855dcddc5aa4fae331af06e7ee7908 /media-video
parentdev-libs/libinput: implement usage of python-any-r1.eclass (diff)
downloadgentoo-932d92b665e50803ed71bc846da723af547c2e49.tar.gz
gentoo-932d92b665e50803ed71bc846da723af547c2e49.tar.bz2
gentoo-932d92b665e50803ed71bc846da723af547c2e49.zip
media-video/libav: update live ebuild
Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/libav/libav-12.3.ebuild4
-rw-r--r--media-video/libav/libav-9999.ebuild21
2 files changed, 13 insertions, 12 deletions
diff --git a/media-video/libav/libav-12.3.ebuild b/media-video/libav/libav-12.3.ebuild
index dc5cf52493f0..b519bf55f1a4 100644
--- a/media-video/libav/libav-12.3.ebuild
+++ b/media-video/libav/libav-12.3.ebuild
@@ -6,7 +6,7 @@ EAPI="6"
inherit flag-o-matic multilib multilib-minimal toolchain-funcs
if [[ ${PV} == *9999 ]] ; then
- : ${EGIT_REPO_URI:="git://git.libav.org/libav.git"}
+ : ${EGIT_REPO_URI:="https://git.libav.org/libav.git"}
if [[ ${PV%9999} != "" ]] ; then
: ${EGIT_BRANCH:="release/${PV%.9999}"}
fi
@@ -345,5 +345,5 @@ multilib_src_install_all() {
multilib_src_test() {
local _libs="$(for i in lib*/;do echo -n "${BUILD_DIR}/${i%/}:";done)"
einfo "LD_LIBRARY_PATH is set to \"${_libs}\""
- LD_LIBRARY_PATH="${_libs}" make -j1 fate V=1
+ LD_LIBRARY_PATH="${_libs}" emake -j1 fate V=1
}
diff --git a/media-video/libav/libav-9999.ebuild b/media-video/libav/libav-9999.ebuild
index ca54c7a80c29..dc8296df27e5 100644
--- a/media-video/libav/libav-9999.ebuild
+++ b/media-video/libav/libav-9999.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI="6"
-inherit eutils flag-o-matic multilib multilib-minimal toolchain-funcs
+inherit flag-o-matic multilib multilib-minimal toolchain-funcs
if [[ ${PV} == *9999 ]] ; then
- : ${EGIT_REPO_URI:="git://git.libav.org/libav.git"}
+ : ${EGIT_REPO_URI:="https://git.libav.org/libav.git"}
if [[ ${PV%9999} != "" ]] ; then
: ${EGIT_BRANCH:="release/${PV%.9999}"}
fi
@@ -19,17 +19,15 @@ if [[ ${PV} == *9999 ]] ; then
SRC_URI=""
elif [[ ${PV%_p*} != ${PV} ]] ; then # Gentoo snapshot
SRC_URI="https://dev.gentoo.org/~lu_zero/libav/${P}.tar.xz"
+ SRC_URI+=" test? ( https://dev.gentoo.org/~lu_zero/libav/fate-${PV}.tar.xz )"
else # Official release
SRC_URI="https://libav.org/releases/${P}.tar.xz"
+ SRC_URI+=" test? ( https://dev.gentoo.org/~lu_zero/libav/fate-${PV%%.*}.tar.xz )"
fi
-# 9999 does not have fate-*.tar.xz
-[[ ${PV%9999} != "" ]] && SRC_URI+=" test? ( https://dev.gentoo.org/~lu_zero/libav/fate-${PV%%.*}.tar.xz )"
LICENSE="LGPL-2.1 gpl? ( GPL-3 )"
SLOT="0/13"
-[[ ${PV} == *9999 ]] || KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64
-~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos
-~x64-solaris ~x86-solaris"
+[[ ${PV} == *9999 ]] || KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
IUSE="aac alsa amr bs2b +bzip2 cdio cpudetection custom-cflags debug doc +encode faac fdk
frei0r fontconfig +gpl gsm +hardcoded-tables ieee1394 jack jpeg2k libressl mp3
+network openssl opus oss pic pulseaudio rtmp schroedinger sdl speex ssl
@@ -143,7 +141,7 @@ src_unpack() {
}
src_prepare() {
- epatch_user
+ eapply_user
# if we have snapshot then we need to hardcode the version
if [[ ${PV%_p*} != ${PV} ]]; then
@@ -154,6 +152,9 @@ src_prepare() {
use zlib && TOOLS+=( cws2fws )
MAKEOPTS+=" V=1"
+
+ # needed at leasts for tests in live ebuild
+ multilib_copy_sources
}
multilib_src_configure() {