summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2017-04-27 22:39:47 +0300
committerDavid Seifert <soap@gentoo.org>2017-05-04 18:27:10 +0200
commit9af33e44316132f988b060aac667b8588167ae9d (patch)
treee2a3e6b70773a2fdd0b0b82099c532ac9fc6e66a /media-video
parentmedia-video/mpv: add LGPL-2.1+ to LICENSE in 9999 (diff)
downloadgentoo-9af33e44316132f988b060aac667b8588167ae9d.tar.gz
gentoo-9af33e44316132f988b060aac667b8588167ae9d.tar.bz2
gentoo-9af33e44316132f988b060aac667b8588167ae9d.zip
media-video/mpv: adjust SSE4.1 intrinsics check in 9999
SSE4.1 intrinsics are built only with ffmpeg-API<3.3. Reorder conditions a bit for a potential speedup. Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mpv/mpv-9999.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 1f527b95990b..e13ffde31611 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -145,7 +145,8 @@ mpv_check_compiler() {
if ( use opengl || use egl ) && ! tc-has-tls; then
die "Your compiler lacks C++11 TLS support. Use GCC>=4.8 or Clang>=3.3."
fi
- if use vaapi && use cpu_flags_x86_sse4_1 && ! tc-is-gcc; then
+ if ! tc-is-gcc && use vaapi && use cpu_flags_x86_sse4_1 && \
+ { has_version '<media-video/ffmpeg-3.3:0' || has_version '<media-video/libav-13:0'; }; then
die "${PN} requires GCC for SSE4.1 intrinsics."
fi
fi