summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-13 14:20:55 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-13 14:20:55 +0100
commit9f02ba239f76ce5edb2725027b86442c1c6ef253 (patch)
tree2d8c0a2d8754af443cab91d0444cda5b5d398194 /media-video
parentmedia-video/mpeg2vidcodec: Port to EAPI 7 (diff)
downloadgentoo-9f02ba239f76ce5edb2725027b86442c1c6ef253.tar.gz
gentoo-9f02ba239f76ce5edb2725027b86442c1c6ef253.tar.bz2
gentoo-9f02ba239f76ce5edb2725027b86442c1c6ef253.zip
media-video/setpwc: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/setpwc/files/setpwc-1.3-fix-build-system.patch23
-rw-r--r--media-video/setpwc/setpwc-1.3.ebuild14
2 files changed, 28 insertions, 9 deletions
diff --git a/media-video/setpwc/files/setpwc-1.3-fix-build-system.patch b/media-video/setpwc/files/setpwc-1.3-fix-build-system.patch
new file mode 100644
index 000000000000..88152cf63669
--- /dev/null
+++ b/media-video/setpwc/files/setpwc-1.3-fix-build-system.patch
@@ -0,0 +1,23 @@
+--- a/Makefile
++++ b/Makefile
+@@ -13,18 +13,13 @@
+ # files in the program, then also delete it here.
+
+ VERSION=1.3
+-CFLAGS+=-Wall -O2 -DVERSION=\"$(VERSION)\"
+-LDFLAGS=
++CFLAGS+=-Wall
++CPPFLAGS+=-DVERSION=\"$(VERSION)\"
+
+ OBJS=setpwc.o
+
+ all: setpwc
+
+-setpwc: $(OBJS)
+- $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o setpwc
+- #
+- # Oh, blatant plug: http://keetweej.vanheusden.com/wishlist.html
+-
+ install: setpwc
+ cp setpwc /usr/bin
+
diff --git a/media-video/setpwc/setpwc-1.3.ebuild b/media-video/setpwc/setpwc-1.3.ebuild
index 562a6b7419a6..cbc20cad7175 100644
--- a/media-video/setpwc/setpwc-1.3.ebuild
+++ b/media-video/setpwc/setpwc-1.3.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
+
inherit toolchain-funcs
DESCRIPTION="Control various aspects of Philips (and compatible) webcams"
@@ -11,18 +12,13 @@ SRC_URI="http://www.vanheusden.com/setpwc/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ppc x86"
-IUSE=""
-RDEPEND=""
DEPEND="sys-kernel/linux-headers"
-src_prepare() {
- sed -i -e '/CFLAGS/s: -O2::' Makefile || die
-}
+PATCHES=( "${FILESDIR}"/${P}-fix-build-system.patch )
-src_compile() {
+src_configure() {
tc-export CC
- emake LDFLAGS="${LDFLAGS}"
}
src_install() {