summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-25 01:05:47 +0000
committerSam James <sam@gentoo.org>2021-10-25 01:05:59 +0000
commita0a2de862f66a5914234dd7561bc8dc63eb7e9ca (patch)
tree2f7fb07c22b9640247ee1b8d4906aa365ef1cb15 /media-video
parentdev-util/android-tools: Fetch patches from dev space (diff)
downloadgentoo-a0a2de862f66a5914234dd7561bc8dc63eb7e9ca.tar.gz
gentoo-a0a2de862f66a5914234dd7561bc8dc63eb7e9ca.tar.bz2
gentoo-a0a2de862f66a5914234dd7561bc8dc63eb7e9ca.zip
media-video/ffmpeg: only add -latomic when supported by compiler/linker
Closes: https://bugs.gentoo.org/820095 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg/ffmpeg-4.4-r1.ebuild2
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild10
2 files changed, 10 insertions, 2 deletions
diff --git a/media-video/ffmpeg/ffmpeg-4.4-r1.ebuild b/media-video/ffmpeg/ffmpeg-4.4-r1.ebuild
index 9dfdeaccd48a..4f4969b77333 100644
--- a/media-video/ffmpeg/ffmpeg-4.4-r1.ebuild
+++ b/media-video/ffmpeg/ffmpeg-4.4-r1.ebuild
@@ -455,7 +455,7 @@ multilib_src_configure() {
if use arm || use ppc ; then
# bug #782811
# bug #790590
- extra_libs+="-latomic "
+ extra_libs+="$(test-flags-CCLD -latomic) "
fi
set -- "${S}/configure" \
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 21212b25c0a4..442b6f27b0f3 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -59,7 +59,7 @@ LICENSE="
samba? ( GPL-3 )
"
if [ "${PV#9999}" = "${PV}" ] ; then
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
# Options to use as use_enable in the foo[:bar] form.
@@ -450,6 +450,13 @@ multilib_src_configure() {
$(multilib_native_enable manpages)
)
+ local extra_libs
+ if use arm || use ppc ; then
+ # bug #782811
+ # bug #790590
+ extra_libs+="$(test-flags-CCLD -latomic) "
+ fi
+
set -- "${S}/configure" \
--prefix="${EPREFIX}/usr" \
--libdir="${EPREFIX}/usr/$(get_libdir)" \
@@ -464,6 +471,7 @@ multilib_src_configure() {
--ranlib="$(tc-getRANLIB)" \
--pkg-config="$(tc-getPKG_CONFIG)" \
--optflags="${CFLAGS}" \
+ --extra-libs="${extra_libs}" \
$(use_enable static-libs static) \
"${myconf[@]}" \
${EXTRA_FFMPEG_CONF}