summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorreagentoo <reagentoo@gmail.com>2020-01-20 11:20:54 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-03 16:50:34 +0100
commita69badca5cba4d1a073fe1c6af9e290015ac2a6e (patch)
tree3352435053bd2f4fbb8eb10c1d37517449449bfc /media-video
parentmedia-libs/webvfx: new package (diff)
downloadgentoo-a69badca5cba4d1a073fe1c6af9e290015ac2a6e.tar.gz
gentoo-a69badca5cba4d1a073fe1c6af9e290015ac2a6e.tar.bz2
gentoo-a69badca5cba4d1a073fe1c6af9e290015ac2a6e.zip
media-video/shotcut: v19.12.31
Closes: https://bugs.gentoo.org/692490 Signed-off-by: Dmitry Baranov <reagentoo@gmail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/shotcut/Manifest1
-rw-r--r--media-video/shotcut/shotcut-19.12.31.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/media-video/shotcut/Manifest b/media-video/shotcut/Manifest
index 8d0867586e9a..e208be1a830e 100644
--- a/media-video/shotcut/Manifest
+++ b/media-video/shotcut/Manifest
@@ -1 +1,2 @@
DIST shotcut-19.06.15.tar.gz 5066141 BLAKE2B ca140045b181287089486f8e7c857ddee29b41727cc9808f37b39118875927a46b0d80558403870b478d2e6b53aadb9acc6456b09560ec94d63c91a5b36bffba SHA512 bf1dbd1233f587ba33dff9c551cdaa22c0ca8bb389c79e817d3eb7af60834b47da2be29872c50125a93e152442a7f7afe8f76f353464334de399dda793d15591
+DIST shotcut-19.12.31.tar.gz 5475620 BLAKE2B 47fd90ddf40da3c08d3dab31b7170b02aab2f3e6b9d3d7446d53192c04b22b7e053cffe21632f1370d699ff00dca0d057f9a49d29ddeb225f039104abbc8ddee SHA512 714d5b3e184e9d0786bc64635e51fd61570e0404c0ebf0fa5c8a12cb85c9091c75ac61e4963bd400b5722f310ae590b2c2d83aa4cd7acbcb53545f224f0ca766
diff --git a/media-video/shotcut/shotcut-19.12.31.ebuild b/media-video/shotcut/shotcut-19.12.31.ebuild
new file mode 100644
index 000000000000..f63ecc276fe4
--- /dev/null
+++ b/media-video/shotcut/shotcut-19.12.31.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic qmake-utils xdg
+
+DESCRIPTION="A free, open source, cross-platform video editor"
+HOMEPAGE="https://www.shotcut.org/ https://github.com/mltframework/shotcut/"
+SRC_URI="https://github.com/mltframework/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgraphicaleffects:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtquickcontrols:5[widgets]
+ dev-qt/qtsql:5
+ dev-qt/qtwebkit:5
+ dev-qt/qtwebsockets:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ >=media-libs/mlt-6.16.0-r1[ffmpeg,frei0r,jack,qt5,sdl,xml]
+ media-libs/webvfx
+ media-video/ffmpeg
+"
+DEPEND="${RDEPEND}
+ dev-qt/qtconcurrent:5
+ dev-qt/qtx11extras:5
+"
+
+src_prepare() {
+ default
+
+ sed -i -e '/QT.*private/d' \
+ src/src.pro || die
+}
+
+src_configure() {
+ append-cxxflags -Wno-deprecated-declarations
+
+ eqmake5 \
+ PREFIX="${EPREFIX}/usr" \
+ SHOTCUT_VERSION="${PV}"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+}