summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-06-10 09:10:21 -0400
committerCraig Andrews <candrews@gentoo.org>2020-06-10 09:10:56 -0400
commitb8d1ccba79828e40ab4a38cd6cad8dc120f55028 (patch)
treef2ef3bd2bec2c8d8e23e663f2c1fc445e004f0b3 /media-video
parentdev-libs/ppl: sparc stable wrt bug #727724 (diff)
downloadgentoo-b8d1ccba79828e40ab4a38cd6cad8dc120f55028.tar.gz
gentoo-b8d1ccba79828e40ab4a38cd6cad8dc120f55028.tar.bz2
gentoo-b8d1ccba79828e40ab4a38cd6cad8dc120f55028.zip
media-video/rtmpdump: add static-libs USE flag
Closes: https://bugs.gentoo.org/727796 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/rtmpdump/rtmpdump-2.4_p20161210-r3.ebuild6
-rw-r--r--media-video/rtmpdump/rtmpdump-9999.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/media-video/rtmpdump/rtmpdump-2.4_p20161210-r3.ebuild b/media-video/rtmpdump/rtmpdump-2.4_p20161210-r3.ebuild
index 5f6a9cd3cb04..09a4ebf6598d 100644
--- a/media-video/rtmpdump/rtmpdump-2.4_p20161210-r3.ebuild
+++ b/media-video/rtmpdump/rtmpdump-2.4_p20161210-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -11,7 +11,7 @@ HOMEPAGE="https://rtmpdump.mplayerhq.hu/"
# the library is LGPL-2.1, the command is GPL-2
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-IUSE="gnutls ssl libressl"
+IUSE="gnutls ssl static-libs libressl"
DEPEND="ssl? (
gnutls? (
@@ -98,4 +98,6 @@ multilib_src_install() {
fi
emake DESTDIR="${D}" prefix="${EPREFIX}/usr" mandir='$(prefix)/share/man' \
CRYPTO="${crypto}" install
+ find "${D}" -name '*.la' -delete || die
+ use static-libs || find "${D}" -name '*.a' -delete || die
}
diff --git a/media-video/rtmpdump/rtmpdump-9999.ebuild b/media-video/rtmpdump/rtmpdump-9999.ebuild
index aef12b6aa94f..df14880ddc1b 100644
--- a/media-video/rtmpdump/rtmpdump-9999.ebuild
+++ b/media-video/rtmpdump/rtmpdump-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -11,7 +11,7 @@ HOMEPAGE="https://rtmpdump.mplayerhq.hu/"
# the library is LGPL-2.1, the command is GPL-2
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-IUSE="gnutls ssl libressl"
+IUSE="gnutls ssl static-libs libressl"
DEPEND="ssl? (
gnutls? (
@@ -98,4 +98,6 @@ multilib_src_install() {
fi
emake DESTDIR="${D}" prefix="${EPREFIX}/usr" mandir='$(prefix)/share/man' \
CRYPTO="${crypto}" install
+ find "${D}" -name '*.la' -delete || die
+ use static-libs || find "${D}" -name '*.a' -delete || die
}