summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2019-11-29 09:49:00 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-11-29 09:49:29 +0200
commitba409b25936da9f200fabe27042891382128a97a (patch)
treecd50fab83878ba9b654f28a95ae433783df915b4 /media-video
parentprofiles: package.mask: remove dev-python/pytest-html (diff)
downloadgentoo-ba409b25936da9f200fabe27042891382128a97a.tar.gz
gentoo-ba409b25936da9f200fabe27042891382128a97a.tar.bz2
gentoo-ba409b25936da9f200fabe27042891382128a97a.zip
media-video/yle-dl: fix dependency on configargparse
- when using yle-dl in ~amd64 or ~x86 systems. Package-Manager: Portage-2.3.80, Repoman-2.3.18 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/yle-dl/yle-dl-20191022-r1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/media-video/yle-dl/yle-dl-20191022-r1.ebuild b/media-video/yle-dl/yle-dl-20191022-r1.ebuild
new file mode 100644
index 000000000000..91b1833ded17
--- /dev/null
+++ b/media-video/yle-dl/yle-dl-20191022-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5..6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Download media files from Yle Areena"
+HOMEPAGE="http://aajanki.github.io/yle-dl/"
+SRC_URI="https://github.com/aajanki/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="libav php test +youtube-dl"
+
+# Requires an active internet connection during tests
+RESTRICT="test"
+
+RDEPEND="
+ !libav? ( media-video/ffmpeg )
+ >=dev-python/attrs-18.1.0[${PYTHON_USEDEP}]
+ <=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ ~dev-python/configargparse-0.13.0[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mini-amf[${PYTHON_USEDEP}]
+ dev-python/progress[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ net-misc/wget
+ php? (
+ dev-lang/php:*[bcmath,cli,curl,simplexml]
+ >=dev-libs/openssl-1.0.2:0=
+ media-video/rtmpdump
+ )
+ youtube-dl? ( net-misc/youtube-dl[${PYTHON_USEDEP}] )
+"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( COPYING ChangeLog README.fi README.md yledl.conf.sample )
+
+src_prepare() {
+ default
+
+ # Gentoo doesn't ship pycryptodomex with pycryptodome
+ sed -i 's/pycryptodomex/pycryptodome/g' setup.py || die
+}
+
+python_test() {
+ # For tests to run succesfully, you need to disable network stricting
+ # feature first.
+ # FEATURES="-network-sandbox test" emerge -a yle-dl
+ esetup.py test
+}
+
+pkg_postinst() {
+ einfo "Sample configuration file has been installed in "
+ einfo " /usr/share/doc/yle-dl-2.37/yledl.conf.sample.bz2"
+}