summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-11-06 12:04:47 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-11-06 12:20:33 +0100
commitd276334e02fd4748584aad9bc304d598d805dd52 (patch)
tree15248b42ee3bc5599bd72372db1eef2a177926ee /media-video
parentsys-devel/clang-runtime: Bump to 7.0.1_rc2 (diff)
downloadgentoo-d276334e02fd4748584aad9bc304d598d805dd52.tar.gz
gentoo-d276334e02fd4748584aad9bc304d598d805dd52.tar.bz2
gentoo-d276334e02fd4748584aad9bc304d598d805dd52.zip
media-video/mplayer: Backport xvmc removal.
Manually cherry picked from 68ad2898bf0b99a7b0cd9ef94d7cc926fb100487 Closes: https://bugs.gentoo.org/655442 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mplayer/metadata.xml1
-rw-r--r--media-video/mplayer/mplayer-1.3.0-r5.ebuild15
2 files changed, 4 insertions, 12 deletions
diff --git a/media-video/mplayer/metadata.xml b/media-video/mplayer/metadata.xml
index d6c05ce054c6..d4d955ac2501 100644
--- a/media-video/mplayer/metadata.xml
+++ b/media-video/mplayer/metadata.xml
@@ -34,7 +34,6 @@
<flag name="twolame">Enable twolame MPEG-2 encoding</flag>
<flag name="vcd">Enables VCD support</flag>
<flag name="vidix">Support for vidix video output</flag>
- <flag name="xvmc">Enables X-Video Motion Compensation support</flag>
<flag name="yuv4mpeg">Enables yuv4mpeg video output</flag>
<flag name="zoran">Enables ZR360[56]7/ZR36060 video output</flag>
</use>
diff --git a/media-video/mplayer/mplayer-1.3.0-r5.ebuild b/media-video/mplayer/mplayer-1.3.0-r5.ebuild
index bd0a05495e9c..82a02d5718b3 100644
--- a/media-video/mplayer/mplayer-1.3.0-r5.ebuild
+++ b/media-video/mplayer/mplayer-1.3.0-r5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,7 +17,7 @@ ftp gif ggi gsm +iconv ipv6 jack joystick jpeg kernel_linux ladspa
+network nut openal opengl +osdmenu oss png pnm pulseaudio pvr
radio rar rtc rtmp samba selinux +shm sdl speex cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_ssse3
tga theora tremor +truetype toolame twolame +unicode v4l vcd vdpau vidix
-vorbis +X x264 xinerama +xscreensaver +xv xvid xvmc yuv4mpeg zoran"
+vorbis +X x264 xinerama +xscreensaver +xv xvid yuv4mpeg zoran"
VIDEO_CARDS="mga tdfx"
for x in ${VIDEO_CARDS}; do
@@ -126,7 +126,6 @@ RDEPEND+="
xinerama? ( x11-libs/libXinerama )
xscreensaver? ( x11-libs/libXScrnSaver )
xv? ( x11-libs/libXv )
- xvmc? ( x11-libs/libXvMC )
"
ASM_DEP="dev-lang/yasm"
@@ -160,7 +159,6 @@ fi
# ass and freetype font require iconv and ass requires freetype fonts
# unicode transformations are usefull only with iconv
# radio requires oss or alsa backend
-# xvmc requires xvideo support
REQUIRED_USE="
dga? ( X )
dvdnav? ( dvd )
@@ -174,8 +172,7 @@ REQUIRED_USE="
vidix? ( X )
xinerama? ( X )
xscreensaver? ( X )
- xv? ( X )
- xvmc? ( xv )"
+ xv? ( X )"
RESTRICT="faac? ( bindist )"
PATCHES=( "${FILESDIR}/${PN}-1.3-vdpau-x11.patch" )
@@ -287,6 +284,7 @@ src_configure() {
--disable-kai
--disable-libopus
--disable-libilbc
+ --disable-xvmc
$(use_enable network networking)
$(use_enable joystick)
"
@@ -494,11 +492,6 @@ src_configure() {
use vidix || myconf+=" --disable-vidix --disable-vidix-pcidb"
use xscreensaver || myconf+=" --disable-xss"
use X || myconf+=" --disable-x11"
- if use xvmc; then
- myconf+=" --enable-xvmc --with-xvmclib=XvMCW"
- else
- myconf+=" --disable-xvmc"
- fi
############################
# OSX (aqua) configuration #