summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2017-09-19 13:39:39 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2017-09-19 13:42:32 +0200
commitdb6e787c45e2f14b53125e68ce49303cd1552f18 (patch)
tree90584c568b6bc57c19859079a9242035392b5be1 /media-video
parentsys-libs/compiler-rt-sanitizers: Remove unused versionator inherit (diff)
downloadgentoo-db6e787c45e2f14b53125e68ce49303cd1552f18.tar.gz
gentoo-db6e787c45e2f14b53125e68ce49303cd1552f18.tar.bz2
gentoo-db6e787c45e2f14b53125e68ce49303cd1552f18.zip
media-video/orion: 1.6.1 bump
Fix desktop file installation, thanks iDarkTemplar at: https://github.com/gentoo/gentoo/pull/5709 Update dependencies Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'media-video')
-rw-r--r--media-video/orion/Manifest1
-rw-r--r--media-video/orion/files/orion-1.6.1-fix_desktop.patch15
-rw-r--r--media-video/orion/orion-1.6.1.ebuild43
3 files changed, 59 insertions, 0 deletions
diff --git a/media-video/orion/Manifest b/media-video/orion/Manifest
index dab82b1ab3f4..41ec92fa03eb 100644
--- a/media-video/orion/Manifest
+++ b/media-video/orion/Manifest
@@ -1,2 +1,3 @@
DIST orion-1.3.5.tar.gz 3213988 SHA256 0094b3202a7cfe0bc5139fd30e0cd371fce76abad3eb019d355dce67b715c8c6 SHA512 afd5540b2a61181c3db051fd39dd42f8a96799d19aab814f5846c5270f13bb0cb8305cd69e09e69cf215aeafb66682cc6d70379e791d6bffc551a38a8c751d0d WHIRLPOOL 8267cf6e261f33161cdadc527bd1ae23f830f903a010a1d58c59cde685a31827e554e992dd26b8ed5c712dcd6548c8500264a3c72c70506962b02dc76bd93593
DIST orion-1.4.0.tar.gz 3375433 SHA256 4adb8ff6a3c24aed14a31d9c17474ee88df52b3cde5d5d1b48b41b4f7a0ae4a0 SHA512 0dadd66f806d9f4bf464e855b38e35cb762ba9cbc1c51a135e5fd489f3a5ebf80117f502eaa8225d0a4a72f15bc8e4858b92866148dc73ecc0d18fd1e1717bed WHIRLPOOL 638ccf87f11eb7c96c949e12d1a97333e156fde5dfb8e1abd315b362e2ddb49748c33a261deb32c531c40f544c8bbb26de681c35b2a32c0cee49888662dabab8
+DIST orion-1.6.1.tar.gz 614216 SHA256 eaa8ace822d3381a1915db82c4203d4ce4e56ec324d4ee18544bd68b00bce749 SHA512 3db0b59a89d2364f2d0586c3f318fc793f73a17d767adb0f44b89830e397be6f24c2ab662b7c84e7d857bc42b952fdf7fa280090313f5e39e37205eb8fb6dc9e WHIRLPOOL d46ed23d9661e2021ad03d5af6a5e50084fca87895649b515fd75ddc4c5afe34382fd0f21c6781abf3760751430aa7c022004897e69b9053e7b62e853036635a
diff --git a/media-video/orion/files/orion-1.6.1-fix_desktop.patch b/media-video/orion/files/orion-1.6.1-fix_desktop.patch
new file mode 100644
index 000000000000..78103fbabea0
--- /dev/null
+++ b/media-video/orion/files/orion-1.6.1-fix_desktop.patch
@@ -0,0 +1,15 @@
+diff -Naur orion-1.6.1.orig/distfiles/Orion.desktop orion-1.6.1/distfiles/Orion.desktop
+--- orion-1.6.1.orig/distfiles/Orion.desktop 2017-07-06 22:26:29.000000000 +0200
++++ orion-1.6.1/distfiles/Orion.desktop 2017-09-19 13:36:49.754743707 +0200
+@@ -2,9 +2,9 @@
+ Version=1.0
+ Type=Application
+ Name=Orion
+-Icon=/usr/local/share/icons/orion.svg
++Icon=orion
+ Exec=/usr/bin/orion
+ Comment=Seek and watch streams on Twitch
+-Categories=Games
++Categories=Game
+ Terminal=false
+ StartupWMClass=orion
diff --git a/media-video/orion/orion-1.6.1.ebuild b/media-video/orion/orion-1.6.1.ebuild
new file mode 100644
index 000000000000..35f439348e2c
--- /dev/null
+++ b/media-video/orion/orion-1.6.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils qmake-utils
+
+DESCRIPTION="Cross-platform Twitch client"
+HOMEPAGE="https://alamminsalo.github.io/orion/"
+SRC_URI="https://github.com/alamminsalo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mpv"
+
+DEPEND="dev-qt/qtquickcontrols2:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebengine:5
+ mpv? ( media-video/mpv[libmpv] )
+ !mpv? ( dev-qt/qtmultimedia:5 )"
+RDEPEND="${DEPEND}
+ !mpv? ( media-plugins/gst-plugins-hls )"
+
+PATCHES=( "${FILESDIR}"/${P}-fix_desktop.patch )
+
+src_configure() {
+ # TODO: also supports qtav, not yet in portage
+ local PLAYER
+ if use mpv; then
+ PLAYER=mpv
+ else
+ PLAYER=multimedia
+ fi
+ eqmake5 ${PN}.pro CONFIG+=${PLAYER}
+}
+
+src_install() {
+ dobin ${PN}
+ domenu distfiles/*.desktop
+
+ insinto /usr/share/icons/hicolor/scalable/apps
+ doins distfiles/${PN}.svg
+}