summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-26 08:44:06 +0100
committerSam James <sam@gentoo.org>2022-07-26 08:44:10 +0100
commitdf321205cf53ef7b8d1f56b0db901748ad25ff05 (patch)
treedb1d6e8855a31e697c6eca888cc598c29a0734d0 /media-video
parentmedia-video/simplescreenrecorder: backport ffmpeg 5 patch (diff)
downloadgentoo-df321205cf53ef7b8d1f56b0db901748ad25ff05.tar.gz
gentoo-df321205cf53ef7b8d1f56b0db901748ad25ff05.tar.bz2
gentoo-df321205cf53ef7b8d1f56b0db901748ad25ff05.zip
media-video/simplescreenrecorder: drop 0.4.3
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/simplescreenrecorder/Manifest1
-rw-r--r--media-video/simplescreenrecorder/simplescreenrecorder-0.4.3.ebuild102
2 files changed, 0 insertions, 103 deletions
diff --git a/media-video/simplescreenrecorder/Manifest b/media-video/simplescreenrecorder/Manifest
index d37af0a63f37..94e6381b4d4d 100644
--- a/media-video/simplescreenrecorder/Manifest
+++ b/media-video/simplescreenrecorder/Manifest
@@ -1,2 +1 @@
-DIST simplescreenrecorder-0.4.3.tar.gz 1918958 BLAKE2B 9d0e07255c7345d8752a8f49fd2e7947db4058c6e6bdbe1239955f96f06543eff24b207bcd049d07eb7d3d5815ad5f1c77721e1fa139f940b1deb3b3da7a46e0 SHA512 c930045d6763bdb026cee80fe82aa0e973de7a1bd92bce9650c5cae627f5d8f8d913f260024410a41170081c8eda61c1aea346bc2d9740b8dc169a3952b3bfd0
DIST simplescreenrecorder-0.4.4.tar.gz 1961269 BLAKE2B 05c7635840f8461ab324f740f0cc554eb544ed91b00cdf39c80f861e6a8631f59afbdcc9fe958830b0f1e31eedb90f11d29c114ce4bbb612f1756264502f069f SHA512 a90549a2709490482d70559073e505e669417a93abf16124b98c021e6d2bf08b91b53eb68e006df4f80fcee9fe4da2624bf8de979618953adb3f37eb1d471525
diff --git a/media-video/simplescreenrecorder/simplescreenrecorder-0.4.3.ebuild b/media-video/simplescreenrecorder/simplescreenrecorder-0.4.3.ebuild
deleted file mode 100644
index b62619102fed..000000000000
--- a/media-video/simplescreenrecorder/simplescreenrecorder-0.4.3.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_ECLASS=cmake
-inherit cmake-multilib flag-o-matic xdg
-
-DESCRIPTION="A Simple Screen Recorder"
-HOMEPAGE="https://www.maartenbaert.be/simplescreenrecorder"
-LICENSE="GPL-3"
-PKGNAME="ssr"
-if [[ ${PV} = 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/MaartenBaert/${PKGNAME}.git"
- EGIT_BOOTSTRAP=""
-else
- SRC_URI="https://github.com/MaartenBaert/${PKGNAME}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 x86"
- S="${WORKDIR}/${PKGNAME}-${PV}"
-fi
-
-SLOT="0"
-IUSE="+asm jack mp3 pulseaudio theora v4l vorbis vpx x264"
-
-RDEPEND="
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dev-qt/qtx11extras:5
- media-libs/alsa-lib:0=
- media-libs/libglvnd[${MULTILIB_USEDEP},X]
- media-video/ffmpeg[vorbis?,vpx?,x264?,mp3?,theora?]
- x11-libs/libX11[${MULTILIB_USEDEP}]
- x11-libs/libXext
- x11-libs/libXfixes[${MULTILIB_USEDEP}]
- x11-libs/libXi
- x11-libs/libXinerama
- virtual/glu[${MULTILIB_USEDEP}]
- v4l? ( media-libs/libv4l )
- jack? ( virtual/jack )
- pulseaudio? ( media-sound/pulseaudio )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="dev-qt/linguist-tools:5"
-
-pkg_pretend() {
- if [[ "${ABI}" == amd64 ]]; then
- elog "You may want to add USE flag 'abi_x86_32' when running a 64bit system"
- elog "When added 32bit GLInject libraries are also included. This is"
- elog "required if you want to use OpenGL recording on 32bit applications."
- elog
- fi
-
- if has_version media-video/ffmpeg[x264] && has_version media-libs/x264[10bit] ; then
- ewarn
- ewarn "media-libs/x264 is currently built with 10bit useflag."
- ewarn "This is known to prevent simplescreenrecorder from recording x264 videos"
- ewarn "correctly. Please build media-libs/x264 without 10bit if you want to "
- ewarn "record videos with x264."
- ewarn
- fi
-}
-
-pkg_setup() {
- # QT requires -fPIC. Compile fails otherwise.
- # Recently removed from the default compile options upstream
- # https://github.com/MaartenBaert/ssr/commit/25fe1743058f0d1f95f6fbb39014b6ac146b5180
- append-flags -fPIC
-}
-
-src_prepare() {
- # required because xdg.eclass overrides default cmake_src_prepare
- cmake_src_prepare
-}
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DENABLE_JACK_METADATA="$(multilib_native_usex jack)"
- -DENABLE_X86_ASM="$(usex asm)"
- -DWITH_PULSEAUDIO="$(multilib_native_usex pulseaudio)"
- -DWITH_JACK="$(multilib_native_usex jack)"
- -DWITH_GLINJECT="true"
- -DWITH_V4L2="$(multilib_native_usex v4l)"
- )
-
- if multilib_is_native_abi ; then
- mycmakeargs+=(
- -DENABLE_32BIT_GLINJECT="false"
- -DWITH_QT5="true"
- )
- else
- mycmakeargs+=(
- # https://bugs.gentoo.org/660438
- -DCMAKE_INSTALL_LIB32DIR="$(get_libdir)"
- -DENABLE_32BIT_GLINJECT="true"
- -DWITH_SIMPLESCREENRECORDER="false"
- )
- fi
-
- cmake_src_configure
-}