summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2023-07-18 00:21:58 +0300
committerJimi Huotari <chiitoo@gentoo.org>2023-07-18 00:45:29 +0300
commite6f0b8e44a3e6c41b643b9d99aea83986cfe2a8e (patch)
treecef5c9644536e4eb74d0c6ad5dfde00e6ed70552 /media-video
parentmedia-video/obs-studio: remove qt5 support (diff)
downloadgentoo-e6f0b8e44a3e6c41b643b9d99aea83986cfe2a8e.tar.gz
gentoo-e6f0b8e44a3e6c41b643b9d99aea83986cfe2a8e.tar.bz2
gentoo-e6f0b8e44a3e6c41b643b9d99aea83986cfe2a8e.zip
media-video/obs-studio: add USE="qsv"
Closes: https://bugs.gentoo.org/910361 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/obs-studio/metadata.xml1
-rw-r--r--media-video/obs-studio/obs-studio-9999.ebuild4
2 files changed, 4 insertions, 1 deletions
diff --git a/media-video/obs-studio/metadata.xml b/media-video/obs-studio/metadata.xml
index 0d746963a49f..9b0f681b3e6d 100644
--- a/media-video/obs-studio/metadata.xml
+++ b/media-video/obs-studio/metadata.xml
@@ -17,6 +17,7 @@
<flag name="fdk">Build with LibFDK AAC support.</flag>
<flag name="pipewire">Build with PipeWire support.</flag>
<flag name="python">Build with scripting support for Python 3.</flag>
+ <flag name="qsv">Build with Intel Quick Sync Video support.</flag>
<flag name="speex">Build with Speex noise suppression filter support.</flag>
<flag name="ssl">Build with TLS/SSL support for RTMPS connections.</flag>
<flag name="vlc">Build with VLC media source support.</flag>
diff --git a/media-video/obs-studio/obs-studio-9999.ebuild b/media-video/obs-studio/obs-studio-9999.ebuild
index 2ece905bf742..d6aec2b41846 100644
--- a/media-video/obs-studio/obs-studio-9999.ebuild
+++ b/media-video/obs-studio/obs-studio-9999.ebuild
@@ -43,7 +43,7 @@ LICENSE="Boost-1.0 GPL-2+ MIT Unlicense"
SLOT="0"
IUSE="
+alsa browser decklink fdk jack lua nvenc pipewire pulseaudio
- python speex +ssl truetype v4l vlc wayland websocket
+ python qsv speex +ssl truetype v4l vlc wayland websocket
"
REQUIRED_USE="
browser? ( || ( alsa pulseaudio ) )
@@ -109,6 +109,7 @@ DEPEND="
pipewire? ( media-video/pipewire:= )
pulseaudio? ( media-libs/libpulse )
python? ( ${PYTHON_DEPS} )
+ qsv? ( media-libs/oneVPL )
speex? ( media-libs/speexdsp )
ssl? ( net-libs/mbedtls:= )
truetype? (
@@ -189,6 +190,7 @@ src_configure() {
-DENABLE_NEW_MPEGTS_OUTPUT=OFF # Requires librist and libsrt.
-DENABLE_PIPEWIRE=$(usex pipewire)
-DENABLE_PULSEAUDIO=$(usex pulseaudio)
+ -DENABLE_QSV11=$(usex qsv)
-DENABLE_RTMPS=$(usex ssl ON OFF) # Needed for bug 880861
-DENABLE_SPEEXDSP=$(usex speex)
-DENABLE_V4L2=$(usex v4l)