summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-13 13:26:52 -0500
committerMatt Turner <mattst88@gentoo.org>2021-03-13 13:32:07 -0500
commitee389595a375f98ca537e514ae76410bb75a9b4b (patch)
treea4b2d2be9799e7f54155f26c1f1af5931b8c3874 /media-video
parentmedia-video/gnome-video-effects: Version bump to 0.5.0 (diff)
downloadgentoo-ee389595a375f98ca537e514ae76410bb75a9b4b.tar.gz
gentoo-ee389595a375f98ca537e514ae76410bb75a9b4b.tar.bz2
gentoo-ee389595a375f98ca537e514ae76410bb75a9b4b.zip
media-video/cheese: Version bump to 3.38.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/cheese/Manifest1
-rw-r--r--media-video/cheese/cheese-3.38.0.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/media-video/cheese/Manifest b/media-video/cheese/Manifest
index c684f352fdab..9d5e7b77261b 100644
--- a/media-video/cheese/Manifest
+++ b/media-video/cheese/Manifest
@@ -1 +1,2 @@
DIST cheese-3.34.0.tar.xz 1077052 BLAKE2B 9719818aebb3472b804d96d79b02ee71b818d098b6eeb54f2075939e95ba651c251d561b4bc79c30a0aae6217a8a29f46f045be9279c9100ba1b0344f1279ba5 SHA512 093b4e5f7f15fd0c445fffd254d4a5035a4e3e91bacccdeeda64a4a7182901646daea5c8596c954a67896f9aaf37dab2309c21e8f026583f59d787a2c1e4c200
+DIST cheese-3.38.0.tar.xz 1086428 BLAKE2B b26a19a019de0385bdd7adbc55c873ebceca90a8f477d2041ef4a5045654f46ee8f7fdfc64f5fd34e059116528cc790610353791a7cbd13d7927a8c3abf38132 SHA512 210b50fc79a7b3a72c94163fe0dd76f7f29f576c1085c671c2c6c3b7f59ee362aec288f885a590ebfd9530534b6a6bad569c6df57874b9fcecf7e9f1ba9531ae
diff --git a/media-video/cheese/cheese-3.38.0.ebuild b/media-video/cheese/cheese-3.38.0.ebuild
new file mode 100644
index 000000000000..c12f4984c2fb
--- /dev/null
+++ b/media-video/cheese/cheese-3.38.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson vala virtualx xdg
+
+DESCRIPTION="A cheesy program to take pictures and videos from your webcam"
+HOMEPAGE="https://wiki.gnome.org/Apps/Cheese"
+
+LICENSE="GPL-2+"
+SLOT="0/8" # subslot = libcheese soname version
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gtk-doc +introspection test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=media-libs/clutter-1.13.2:1.0[introspection?]
+ media-libs/clutter-gst:3.0
+ >=media-libs/clutter-gtk-0.91.8:1.0
+ x11-libs/gdk-pixbuf:2[jpeg,introspection?]
+ >=dev-libs/glib-2.39.90:2
+ >=gnome-base/gnome-desktop-2.91.6:3=
+ >=media-libs/gstreamer-1.4:1.0[introspection?]
+ >=media-libs/gst-plugins-base-1.4:1.0[ogg,pango,theora,vorbis]
+ >=media-libs/gst-plugins-bad-1.4:1.0
+ >=x11-libs/gtk+-3.13.4:3
+ >=media-libs/libcanberra-0.26[gtk3]
+ x11-libs/libX11
+ sys-apps/dbus
+ media-video/gnome-video-effects
+ introspection? ( >=dev-libs/gobject-introspection-1.56:= )
+
+ media-libs/cogl:1.0=[introspection?]
+
+"
+RDEPEND="${DEPEND}
+ >=media-libs/gst-plugins-good-1.4:1.0
+
+ >=media-plugins/gst-plugins-jpeg-1.4:1.0
+ >=media-plugins/gst-plugins-v4l2-1.4:1.0
+ >=media-plugins/gst-plugins-vpx-1.4:1.0
+"
+
+BDEPEND="
+ gtk-doc? ( dev-util/gtk-doc )
+ dev-libs/libxslt
+ app-text/docbook-xml-dtd:4.3
+ dev-util/itstool
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ test? ( x11-libs/libXtst )
+ $(vala_depend)
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-buildfix.patch
+)
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection)
+ $(meson_use test tests)
+ -Dman=true
+ )
+
+ meson_src_configure
+
+ # Hack: version.xml is not generated if gtk-doc is not enabled
+ echo ${PV} > docs/reference/version.xml
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}