summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-18 22:37:55 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-21 17:30:01 +0200
commit9520fd88a9f8f9a8141e51a53305a5ee13195bd8 (patch)
treec3c88d9c0661dc27c9ade69cd52af25ffd36104d /metadata/install-qa-check.d
parentdev-libs/libstrophe: add new version 0.10.0 (diff)
downloadgentoo-9520fd88a9f8f9a8141e51a53305a5ee13195bd8.tar.gz
gentoo-9520fd88a9f8f9a8141e51a53305a5ee13195bd8.tar.bz2
gentoo-9520fd88a9f8f9a8141e51a53305a5ee13195bd8.zip
install-qa-check.d: add DISTUTILS_USE_SETUPTOOLS check
Move DISTUTILS_USE_SETUPTOOLS check from distutils-r1.eclass to install QA checks, and rewrite it to use installed egg-info rather than greps on input files. This produces less false positives, particularly in packages that use boilerplate empty 'entry_points' in their setup script or configuration file. We also no longer require explicit setuptools RDEPEND for packages using other entry point types than console_scripts -- instead, we assume that the package consuming these entry points will bring setuptools as necessary. The rough idea is to look at egg-info metadata installed by distutils or setuptools. Plain distutils installs it as a regular file, while setuptools as a directory, and that's how we distinguish the two. For setuptools, we additionally grep entry_points.txt for `[console_scripts]`, and require RDEPEND when they are present. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'metadata/install-qa-check.d')
-rw-r--r--metadata/install-qa-check.d/60distutils-use-setuptools60
1 files changed, 60 insertions, 0 deletions
diff --git a/metadata/install-qa-check.d/60distutils-use-setuptools b/metadata/install-qa-check.d/60distutils-use-setuptools
new file mode 100644
index 000000000000..db07212cce48
--- /dev/null
+++ b/metadata/install-qa-check.d/60distutils-use-setuptools
@@ -0,0 +1,60 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# QA check: verify correctness of DISTUTILS_USE_SETUPTOOLS
+# Maintainer: Python project <python@gentoo.org>
+
+get_expected_distutils_use_setuptools() {
+ local sitedir=${D}$(python_get_sitedir)
+ local egg new_expected
+ while read -d $'\0' -r egg; do
+ if [[ -f ${egg} ]]; then
+ # if .egg-info is a file, it's plain distutils
+ new_expected=no
+ elif grep -q -s -F '[console_scripts]' "${egg}"/entry_points.txt
+ then
+ # entry_points == we need rdepend
+ new_expected=rdepend
+ else
+ new_expected=bdepend
+ fi
+
+ if [[ ${expected} && ${new_expected} != ${expected} ]]; then
+ expected=integrity-error
+ else
+ expected=${new_expected}
+ fi
+ done < <(find "${sitedir}" -name '*.egg-info' -print0)
+}
+
+distutils_use_setuptools_check() {
+ # applicable only to ebuilds inheriting distutils-r1
+ [[ ${_DISTUTILS_R1} ]] || return
+ # 'manual' means no checking
+ [[ ${DISTUTILS_USE_SETUPTOOLS} == manual ]] && return
+ # pyproject.toml is verified by using it
+ [[ ${DISTUTILS_USE_SETUPTOOLS} == pyproject.toml ]] && return
+
+ local expected
+ _distutils-r1_run_foreach_impl get_expected_distutils_use_setuptools
+
+ if [[ ${expected} == integrity-error ]]; then
+ eerror "DISTUTILS_USE_SETUPTOOLS integrity error!"
+ eerror "expected was: ${expected}"
+ eerror "new_expected is: ${new_expected}"
+ eerror "Please report a bug about this and CC python@"
+ elif [[ ${DISTUTILS_USE_SETUPTOOLS} != ${expected} ]]; then
+ local def=
+ [[ ${DISTUTILS_USE_SETUPTOOLS} == bdepend ]] && def=' (or unset)'
+
+ eqawarn "DISTUTILS_USE_SETUPTOOLS value is probably incorrect"
+ eqawarn " have: DISTUTILS_USE_SETUPTOOLS=${DISTUTILS_USE_SETUPTOOLS}${def}"
+ eqawarn " expected: DISTUTILS_USE_SETUPTOOLS=${expected}"
+ fi
+}
+
+distutils_use_setuptools_check
+
+: # guarantee successful exit
+
+# vim:ft=ebuild