summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-10-27 21:07:21 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-10-27 21:09:08 -0400
commitffcaf94ff152614f9e127aee04f87c0e37fcd833 (patch)
tree205906d09e4698a14c05b3538544bb94b4c02149 /net-analyzer/2ping/2ping-3.0.0.ebuild
parentsys-kernel/gentoo-sources: Linux patch 3.10.92 (diff)
downloadgentoo-ffcaf94ff152614f9e127aee04f87c0e37fcd833.tar.gz
gentoo-ffcaf94ff152614f9e127aee04f87c0e37fcd833.tar.bz2
gentoo-ffcaf94ff152614f9e127aee04f87c0e37fcd833.zip
net-analyzer/2ping: version bump to 3.0.0.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-analyzer/2ping/2ping-3.0.0.ebuild')
-rw-r--r--net-analyzer/2ping/2ping-3.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-analyzer/2ping/2ping-3.0.0.ebuild b/net-analyzer/2ping/2ping-3.0.0.ebuild
new file mode 100644
index 000000000000..4c311b30f1b3
--- /dev/null
+++ b/net-analyzer/2ping/2ping-3.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A bi-directional ping utility"
+HOMEPAGE="http://www.finnie.org/software/2ping/"
+SRC_URI="http://www.finnie.org/software/2ping/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="server"
+
+src_install() {
+ distutils-r1_src_install
+ doman doc/2ping.1
+ dodoc doc/{2ping-protocol-examples.py,2ping-protocol.md}
+ use server && {
+ doinitd "${FILESDIR}"/2pingd
+ newconfd "${FILESDIR}"/2pingd.conf 2pingd
+ }
+}