summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-08-12 08:03:22 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-08-12 08:03:22 -0400
commit72bffd66bb4c55be3773248405e7784e6eec47c9 (patch)
tree9b9bc9d21985f7b2fca8e43e5fa21b6fd5327819 /net-analyzer/2ping/2ping-4.2.ebuild
parentapp-backup/borgbackup: remove older versions (diff)
downloadgentoo-72bffd66bb4c55be3773248405e7784e6eec47c9.tar.gz
gentoo-72bffd66bb4c55be3773248405e7784e6eec47c9.tar.bz2
gentoo-72bffd66bb4c55be3773248405e7784e6eec47c9.zip
net-analyzer/2ping: version bump to 4.2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-analyzer/2ping/2ping-4.2.ebuild')
-rw-r--r--net-analyzer/2ping/2ping-4.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-analyzer/2ping/2ping-4.2.ebuild b/net-analyzer/2ping/2ping-4.2.ebuild
new file mode 100644
index 000000000000..688c698a7823
--- /dev/null
+++ b/net-analyzer/2ping/2ping-4.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A bi-directional ping utility"
+HOMEPAGE="https://www.finnie.org/software/2ping/"
+SRC_URI="https://www.finnie.org/software/2ping/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="server"
+
+src_install() {
+ distutils-r1_src_install
+ doman doc/2ping.1
+ dodoc doc/{2ping-protocol-examples.py,2ping-protocol.md}
+ use server && {
+ doinitd "${FILESDIR}"/2pingd
+ newconfd "${FILESDIR}"/2pingd.conf 2pingd
+ }
+}