summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-17 09:36:35 +0000
committerSam James <sam@gentoo.org>2023-02-17 09:48:22 +0000
commit8b68f5bbd45d6781892ad0467fa87ececfb6d26e (patch)
tree362fe749cccf957548d220b4e6d715ba185b05ac /net-analyzer/2ping/2ping-4.5.1-r1.ebuild
parentdev-python/snaketrace: enable py3.11, use PEP517 (diff)
downloadgentoo-8b68f5bbd45d6781892ad0467fa87ececfb6d26e.tar.gz
gentoo-8b68f5bbd45d6781892ad0467fa87ececfb6d26e.tar.bz2
gentoo-8b68f5bbd45d6781892ad0467fa87ececfb6d26e.zip
net-analyzer/2ping: enable py3.11, use PEP517, install bash completions
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/2ping/2ping-4.5.1-r1.ebuild')
-rw-r--r--net-analyzer/2ping/2ping-4.5.1-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-analyzer/2ping/2ping-4.5.1-r1.ebuild b/net-analyzer/2ping/2ping-4.5.1-r1.ebuild
new file mode 100644
index 000000000000..e26ab3b49f42
--- /dev/null
+++ b/net-analyzer/2ping/2ping-4.5.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="A bi-directional ping utility"
+HOMEPAGE="https://www.finnie.org/software/2ping/"
+SRC_URI="https://www.finnie.org/software/2ping/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~riscv ~x86"
+IUSE="server"
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ doman doc/2ping.1
+ dodoc doc/{2ping-protocol-examples.py,2ping-protocol.md}
+
+ newbashcomp 2ping.bash_completion 2ping
+ dosym 2ping $(get_bashcompdir)/2ping6
+
+ use server && {
+ doinitd "${FILESDIR}"/2pingd
+ newconfd "${FILESDIR}"/2pingd.conf 2pingd
+ }
+}