summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-02-01 01:15:26 +0100
committerJeroen Roovers <jer@gentoo.org>2020-02-01 01:15:49 +0100
commit045fce9aa45279bdbbfa9ce0e4b844f32ef7d337 (patch)
treec33ac71f75e51a7a905c525d380bac1188fbd033 /net-analyzer/apinger/apinger-0.4.1-r1.ebuild
parentapp-admin/mcelog: Drop old versions (diff)
downloadgentoo-045fce9aa45279bdbbfa9ce0e4b844f32ef7d337.tar.gz
gentoo-045fce9aa45279bdbbfa9ce0e4b844f32ef7d337.tar.bz2
gentoo-045fce9aa45279bdbbfa9ce0e4b844f32ef7d337.zip
net-analyzer/apinger: Fix CFLAGS=-fno-common
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Closes: https://bugs.gentoo.org/show_bug.cgi?id=707596 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/apinger/apinger-0.4.1-r1.ebuild')
-rw-r--r--net-analyzer/apinger/apinger-0.4.1-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-analyzer/apinger/apinger-0.4.1-r1.ebuild b/net-analyzer/apinger/apinger-0.4.1-r1.ebuild
new file mode 100644
index 000000000000..9126a208502a
--- /dev/null
+++ b/net-analyzer/apinger/apinger-0.4.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Alarm Pinger"
+HOMEPAGE="https://github.com/Jajcus/apinger/"
+SRC_URI="https://github.com/Jajcus/apinger/archive/${PN^^}_${PV//./_}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ sys-devel/flex
+ virtual/yacc
+"
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.1-fno-common.patch
+ "${FILESDIR}"/${PN}-0.4.1-stray-backslash.patch
+)
+S="${WORKDIR}/${PN}-${PN^^}_${PV//./_}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ emake -C src/ cfgparser1.h
+ default
+}
+
+src_install() {
+ default
+ insinto /etc
+ doins src/${PN}.conf
+}