summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-06-10 07:05:42 +0200
committerJeroen Roovers <jer@gentoo.org>2016-06-10 07:11:31 +0200
commit2ca68231044120e14a9d8e1778841b9781ea8b4d (patch)
tree5983b45e54799800ebe2416e6e48e6f512b9e28d /net-analyzer/argus-clients/argus-clients-3.0.8.2.ebuild
parentnet-misc/iperf: Version bump. (diff)
downloadgentoo-2ca68231044120e14a9d8e1778841b9781ea8b4d.tar.gz
gentoo-2ca68231044120e14a9d8e1778841b9781ea8b4d.tar.bz2
gentoo-2ca68231044120e14a9d8e1778841b9781ea8b4d.zip
net-analyzer/argus-clients: Version bump.
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'net-analyzer/argus-clients/argus-clients-3.0.8.2.ebuild')
-rw-r--r--net-analyzer/argus-clients/argus-clients-3.0.8.2.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/net-analyzer/argus-clients/argus-clients-3.0.8.2.ebuild b/net-analyzer/argus-clients/argus-clients-3.0.8.2.ebuild
new file mode 100644
index 000000000000..6fded8c6a040
--- /dev/null
+++ b/net-analyzer/argus-clients/argus-clients-3.0.8.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="Clients for net-analyzer/argus"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="http://qosient.com/argus/dev/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug ft geoip mysql sasl tcpd"
+
+MY_CDEPEND="
+ net-analyzer/rrdtool[perl]
+ net-libs/libpcap
+ sys-libs/ncurses
+ sys-libs/readline
+ sys-libs/zlib
+ ft? ( net-analyzer/flow-tools )
+ geoip? ( dev-libs/geoip )
+ mysql? ( virtual/mysql )
+ sasl? ( dev-libs/cyrus-sasl )
+"
+
+RDEPEND="
+ ${MY_CDEPEND}
+"
+
+DEPEND="
+ ${MY_CDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-3.0.4.1-disable-tcp-wrappers-automagic.patch \
+ "${FILESDIR}"/${PN}-3.0.7.21-curses-readline.patch
+
+ sed -i -e 's| ar | $(AR) |g' common/Makefile.in || die
+ tc-export AR RANLIB
+
+ eautoreconf
+}
+
+src_configure() {
+ use debug && touch .debug
+ econf \
+ $(use_with ft libft) \
+ $(use_with geoip GeoIP /usr/) \
+ $(use_with sasl) \
+ $(use_with tcpd wrappers) \
+ $(use_with mysql)
+}
+
+src_compile() {
+ # racurses uses both libncurses and libtinfo, if present
+ emake \
+ CCOPT="${CFLAGS} ${LDFLAGS}" \
+ RANLIB=$(tc-getRANLIB) \
+ CURSESLIB="$( $(tc-getPKG_CONFIG) --libs ncurses)"
+}
+
+src_install() {
+ dobin bin/ra*
+ dodoc ChangeLog CREDITS README CHANGES
+ doman man/man{1,5}/*
+}