summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-09-25 12:38:37 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-11-01 23:04:47 +0100
commitc2585aef6d159695ac0a5dc600245507973e82ef (patch)
treed57f37e7f34b1e21cb39b528220037bd138daf2e /net-analyzer/argus/argus-3.0.8.2-r1.ebuild
parentdev-perl/Module-Build-XSUtil: Bump to version 0.180.0 (diff)
downloadgentoo-c2585aef6d159695ac0a5dc600245507973e82ef.tar.gz
gentoo-c2585aef6d159695ac0a5dc600245507973e82ef.tar.bz2
gentoo-c2585aef6d159695ac0a5dc600245507973e82ef.zip
net-analyzer/argus: Add option to build against libtirpc for RPC support, bug 631474
Closes: https://bugs.gentoo.org/631474 Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'net-analyzer/argus/argus-3.0.8.2-r1.ebuild')
-rw-r--r--net-analyzer/argus/argus-3.0.8.2-r1.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/net-analyzer/argus/argus-3.0.8.2-r1.ebuild b/net-analyzer/argus/argus-3.0.8.2-r1.ebuild
new file mode 100644
index 000000000000..4484cf276e72
--- /dev/null
+++ b/net-analyzer/argus/argus-3.0.8.2-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils user
+
+DESCRIPTION="network Audit Record Generation and Utilization System"
+HOMEPAGE="http://www.qosient.com/argus/"
+SRC_URI="${HOMEPAGE}dev/${P/_rc/.rc.}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="debug +libtirpc sasl tcpd"
+
+RDEPEND="
+ net-libs/libpcap
+ sys-libs/zlib
+ !libtirpc? ( sys-libs/glibc[rpc(-)] )
+ libtirpc? ( net-libs/libtirpc )
+ sasl? ( dev-libs/cyrus-sasl )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+"
+
+DEPEND="
+ ${RDEPEND}
+ >=sys-devel/bison-1.28
+ >=sys-devel/flex-2.4.6
+"
+
+S=${WORKDIR}/${P/_rc/.rc.}
+
+src_prepare() {
+ find . -type f -execdir chmod +w {} \; #561360
+ sed -e 's:/etc/argus.conf:/etc/argus/argus.conf:' \
+ -i argus/argus.c \
+ -i support/Config/argus.conf \
+ -i man/man8/argus.8 \
+ -i man/man5/argus.conf.5 || die
+
+ sed -e 's:#\(ARGUS_SETUSER_ID=\).*:\1argus:' \
+ -e 's:#\(ARGUS_SETGROUP_ID=\).*:\1argus:' \
+ -e 's:\(#ARGUS_CHROOT_DIR=\).*:\1/var/lib/argus:' \
+ -i support/Config/argus.conf || die
+ epatch \
+ "${FILESDIR}"/${PN}-3.0.8.1-disable-tcp-wrappers-automagic.patch \
+ "${FILESDIR}"/${PN}-3.0.5-Makefile.patch \
+ "${FILESDIR}"/${PN}-3.0.7.3-DLT_IPNET.patch \
+ "${FILESDIR}"/${PN}-3.0.8.2-rpc.patch
+
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ use debug && touch .debug # enable debugging
+ econf $(use_with libtirpc) $(use_with tcpd wrappers) $(use_with sasl)
+}
+
+src_compile() {
+ emake CCOPT="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install () {
+ doman man/man5/*.5 man/man8/*.8
+
+ dosbin bin/argus{,bug}
+
+ dodoc ChangeLog CREDITS README
+
+ insinto /etc/argus
+ doins support/Config/argus.conf
+
+ newinitd "${FILESDIR}/argus.initd" argus
+ keepdir /var/lib/argus
+}
+
+pkg_preinst() {
+ enewgroup argus
+ enewuser argus -1 -1 /var/lib/argus argus
+}
+
+pkg_postinst() {
+ elog "Note, if you modify ARGUS_DAEMON value in argus.conf it's quite"
+ elog "possible that the init script will fail to work."
+}