summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/cacti-spine/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/cacti-spine/files')
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-mysql.patch11
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-ping.patch11
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-snmp_spine_close.patch10
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-0.8.8e-fix-ac-macro.patch11
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-0.8.8e-net-snmp.patch19
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-0.8.8f-fix-ac-macro.patch11
6 files changed, 73 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-mysql.patch b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-mysql.patch
new file mode 100644
index 000000000000..d60653678a2c
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-mysql.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -239,7 +239,7 @@
+ fi
+ CFLAGS="-I$MYSQL_INC_DIR $CFLAGS"
+
+-AC_CHECK_LIB(mysqlclient_r,mysql_init, LIBS="-lmysqlclient_r",
++AC_CHECK_LIB(mysqlclient_r,mysql_init, LIBS="$LIBS -lmysqlclient_r",
+ AC_MSG_ERROR([MySQL libraries not found])
+ )
+
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-ping.patch b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-ping.patch
new file mode 100644
index 000000000000..0d94674ce5a3
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-ping.patch
@@ -0,0 +1,11 @@
+--- a/ping.c
++++ b/ping.c
+@@ -813,7 +813,7 @@
+ int rv;
+
+ buf = malloc(len*sizeof(char));
+- memset(buf, 0, sizeof(buf));
++ memset(buf, 0, len*sizeof(char));
+
+ while (1) {
+ rv = gethostbyname_r(hostname, &result_buf, buf, len,
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-snmp_spine_close.patch b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-snmp_spine_close.patch
new file mode 100644
index 000000000000..f39e8c6575e1
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8d-snmp_spine_close.patch
@@ -0,0 +1,10 @@
+--- a/snmp.h
++++ b/snmp.h
+@@ -32,6 +32,7 @@
+ */
+
+ extern void snmp_spine_init(void);
++extern void snmp_spine_close(void);
+ extern void *snmp_host_init(int host_id, char *hostname, int snmp_version, char *snmp_community, char *snmp_username, char *snmp_password, char *snmp_auth_protocol, char *snmp_priv_passphrase, char *snmp_priv_protocol, char *snmp_context, int snmp_port, int snmp_timeout);
+ extern void snmp_host_cleanup(void *snmp_session);
+ extern char *snmp_get(host_t *current_host, char *snmp_oid);
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-0.8.8e-fix-ac-macro.patch b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8e-fix-ac-macro.patch
new file mode 100644
index 000000000000..5249cdf9386b
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8e-fix-ac-macro.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -10,7 +10,7 @@
+ AC_LANG(C)
+
+ AM_INIT_AUTOMAKE(spine, 0.8.8e)
+-AM_CONFIG_HEADER(config/config.h)
++AC_CONFIG_HEADERS(config/config.h)
+
+ # static libraries
+ AC_ARG_WITH(static,
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-0.8.8e-net-snmp.patch b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8e-net-snmp.patch
new file mode 100644
index 000000000000..c96bbc9a7322
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8e-net-snmp.patch
@@ -0,0 +1,19 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -254,14 +254,14 @@
+ )
+
+ AC_MSG_CHECKING([if Net-SNMP needs crypto support])
+-AC_TRY_COMPILE([#include <net-snmp-config.h>], [exit(USE_OPENSSL != 1);],
++AC_TRY_COMPILE([#include <net-snmp/net-snmp-config.h>], [exit(USE_OPENSSL != 1);],
+ [ AC_MSG_RESULT(yes)
+ SNMP_SSL=yes
+ ],
+ AC_MSG_RESULT(no)
+ )
+
+-AC_TRY_COMPILE([ #include <net-snmp-config.h>
++AC_TRY_COMPILE([ #include <net-snmp/net-snmp-config.h>
+ #include <net-snmp/utilities.h>
+ #include <net-snmp/net-snmp-includes.h>
+ #include <net-snmp/config_api.h>
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-0.8.8f-fix-ac-macro.patch b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8f-fix-ac-macro.patch
new file mode 100644
index 000000000000..a879d5e0bf96
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8f-fix-ac-macro.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -10,7 +10,7 @@
+ AC_LANG(C)
+
+ AM_INIT_AUTOMAKE(spine, 0.8.8f)
+-AM_CONFIG_HEADER(config/config.h)
++AC_CONFIG_HEADERS(config/config.h)
+
+ # static libraries
+ AC_ARG_WITH(static,