summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-10 03:40:37 +0000
committerSam James <sam@gentoo.org>2021-12-10 03:48:55 +0000
commit3ab7ffa686e3e09293631319aedf3def59174d18 (patch)
tree5f02079b7d3fdf831a8a6822b063ca1c00ed3869 /net-analyzer/cacti-spine
parentnet-analyzer/cacti: add 1.2.19 (diff)
downloadgentoo-3ab7ffa686e3e09293631319aedf3def59174d18.tar.gz
gentoo-3ab7ffa686e3e09293631319aedf3def59174d18.tar.bz2
gentoo-3ab7ffa686e3e09293631319aedf3def59174d18.zip
net-analyzer/cacti-spine: add 1.2.19
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/cacti-spine')
-rw-r--r--net-analyzer/cacti-spine/Manifest1
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.2.19.ebuild47
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-9999.ebuild (renamed from net-analyzer/cacti-spine/cacti-spine-99999.ebuild)16
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-1.2.19-configure.ac-fix-bashisms.patch33
4 files changed, 87 insertions, 10 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
index 9d350c261ff8..f0c5a377c342 100644
--- a/net-analyzer/cacti-spine/Manifest
+++ b/net-analyzer/cacti-spine/Manifest
@@ -1,2 +1,3 @@
DIST cacti-spine-1.2.16.tar.gz 108252 BLAKE2B ba0349cff7f4e82a5dc1d90c216cf7a4e0f939e28ab20d008b1725c948a85a00e2594f8997c8bbd69c305e3e58d944858c8439210956f45220b67229bc6df13d SHA512 0259084d70f9c8d20a8b19daf61e525228f99fba3eac4e2e5c9865114a5f1231b18389ca955fc4644c71c6c48cc45dda9b17e969a02c80552b84f98ad8945951
DIST cacti-spine-1.2.17.tar.gz 110371 BLAKE2B 1f9605d34fcff0e4e7921ccbb5a22eeb9e2f2e2f22cf56189790dcdec798db5bff681df11cd82006254cc270174248c07ce3d94dca8d3367add6b220f1599adf SHA512 4c616af041d2f08e18fd274409c98d3efce84b7cca2d6e23db3d6c2a0d4c9a77a2c52c0ef8e0ed0c6ad409f28b56fdf3160e27654522d8aeb1b88e3cb4128d4a
+DIST cacti-spine-1.2.19.tar.gz 113974 BLAKE2B 6ec71e1480e9dfd2636c61bcea10c6581009908334fddbaab5cf4bf6948bc6f8ffb27b0325ab1f325b9ad0b0f2ba7e018373c34534ca5d4967f66100fba76934 SHA512 407a4e83aabaa62693c2f7c3d3952da9178bb28e2b8b914a5649e3eaccb9ea77d0c7db8e251a113a308bfaaa0674be941abfb2fc4f8e50d43fb73c8cd9deec63
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.2.19.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.2.19.ebuild
new file mode 100644
index 000000000000..d70a52735b10
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-1.2.19.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="https://cacti.net/spine_info.php"
+SRC_URI="https://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+BDEPEND="sys-apps/help2man"
+DEPEND="dev-libs/openssl:=
+ net-analyzer/net-snmp:=
+ dev-db/mysql-connector-c:0="
+RDEPEND="
+ ${DEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
+ "${FILESDIR}"/${PN}-1.2.19-configure.ac-fix-bashisms.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ dosbin spine
+
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+
+ doman spine.1
+ dodoc CHANGELOG
+}
diff --git a/net-analyzer/cacti-spine/cacti-spine-99999.ebuild b/net-analyzer/cacti-spine/cacti-spine-9999.ebuild
index d929a4df7fcb..cfc27aa3907f 100644
--- a/net-analyzer/cacti-spine/cacti-spine-99999.ebuild
+++ b/net-analyzer/cacti-spine/cacti-spine-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools git-r3
@@ -13,18 +13,13 @@ EGIT_REPO_URI="https://github.com/Cacti/spine"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS=""
BDEPEND="sys-apps/help2man"
-DEPEND="
- dev-libs/openssl:0=
+DEPEND="dev-libs/openssl:=
net-analyzer/net-snmp:=
- dev-db/mysql-connector-c:0=
-"
-RDEPEND="
- ${DEPEND}
- >net-analyzer/cacti-0.8.8
-"
+ dev-db/mysql-connector-c:0="
+RDEPEND="${DEPEND}
+ >net-analyzer/cacti-0.8.8"
PATCHES=(
"${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
@@ -32,6 +27,7 @@ PATCHES=(
src_prepare() {
default
+
eautoreconf
}
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-1.2.19-configure.ac-fix-bashisms.patch b/net-analyzer/cacti-spine/files/cacti-spine-1.2.19-configure.ac-fix-bashisms.patch
new file mode 100644
index 000000000000..53a220fbf0de
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-1.2.19-configure.ac-fix-bashisms.patch
@@ -0,0 +1,33 @@
+https://github.com/Cacti/spine/pull/245
+
+From: Sam James <sam@gentoo.org>
+Date: Fri, 10 Dec 2021 03:42:21 +0000
+Subject: [PATCH] configure.ac: fix bashisms
+
+configure needs to work with a POSIX-compliant shell so we need
+to avoid bashisms like '=='. This fixes configure with e.g. /bin/sh
+provided by dash.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/configure.ac
++++ b/configure.ac
+@@ -260,7 +260,7 @@ fi
+ CFLAGS="-I$MYSQL_INC_DIR $CFLAGS"
+
+ unamestr=$(uname)
+-if test $unamestr == 'OpenBSD'; then
++if test $unamestr = 'OpenBSD'; then
+ AC_CHECK_LIB(mysqlclient, mysql_init,
+ [ LIBS="-lmysqlclient -lm $LIBS"
+ AC_DEFINE(HAVE_MYSQL, 1, MySQL Client API)
+@@ -285,8 +285,8 @@ else
+ if test -f $MYSQL_LIB_DIR/libmysqlclient_r.a -o -f $MYSQL_LIB_DIR/libmysqlclient_r.$ShLib ; then
+ LIBS="-lmysqlclient_r -lm -ldl $LIBS"
+ else
+- if test "$HAVE_MYSQL" == "yes"; then
+- if test $unamestr == 'OpenBSD'; then
++ if test "$HAVE_MYSQL" = "yes"; then
++ if test $unamestr = 'OpenBSD'; then
+ LIBS="-lmysqlclient -lm $LIBS"
+ else
+ LIBS="-lmysqlclient -lm -ldl $LIBS"