summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-03-01 08:35:11 +0100
committerJeroen Roovers <jer@gentoo.org>2017-03-01 08:36:30 +0100
commitc21e3dd6568aef9c21e586d04624691cd0f635c5 (patch)
tree5d5901c8767eef0a1a0c4a091abf055368f3c99a /net-analyzer/cacti-spine
parentnet-analyzer/cacti: Version bump. (diff)
downloadgentoo-c21e3dd6568aef9c21e586d04624691cd0f635c5.tar.gz
gentoo-c21e3dd6568aef9c21e586d04624691cd0f635c5.tar.bz2
gentoo-c21e3dd6568aef9c21e586d04624691cd0f635c5.zip
net-analyzer/cacti-spine: Version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-analyzer/cacti-spine')
-rw-r--r--net-analyzer/cacti-spine/Manifest1
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.0.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
index 8bed9b8e5c5a..dc2eca843fcf 100644
--- a/net-analyzer/cacti-spine/Manifest
+++ b/net-analyzer/cacti-spine/Manifest
@@ -3,3 +3,4 @@ DIST cacti-spine-1.0.0.tar.gz 800770 SHA256 074528eec16e8a49d535ce96d2347bd2a891
DIST cacti-spine-1.0.1.tar.gz 800797 SHA256 75b699bd4a85389a4fe026423aae97b51e9f6b091cffbfb6b41d5785d7423330 SHA512 c5b2f22c6304f5a95e3db58609fb430fc3fb1ba01de6a0817bc6d86ea94af791e55a4985496980b472ce88723ee498dbb4e8a004be4d41e61b795a7b510af999 WHIRLPOOL a67b29de02b0b21cdd65c8c1aefd89a1b0c74eff4ab7dcb6395ed2bff8d0d14f32c579df8c55adca0e3b6c1d9dd01693b19db54efdb80ec10042913bcfc4cef7
DIST cacti-spine-1.0.2.tar.gz 800868 SHA256 02137dcfe2e04e8e1ab9bc955afbd2cf6368749280eed027a5a46176b00e230a SHA512 6a872ec82861c08f4f02d1e070683011caa64d613c3fef54b002e545e607ef3be0d9ed841ca061eedaa2b25d8116f93b143dd4f829bd13e20c48f9565ff72678 WHIRLPOOL b79b14923bd052e09c5b3f3aa79a765ba813bf980433916bb479be4552239f305ea735120fd5c1ff842adce01d1ba3f8809b85628ecaed0ed79c49be5fe13e06
DIST cacti-spine-1.0.3.tar.gz 800855 SHA256 f63f90f0c81d72cdb6a8b7c64cc2d341e34ccf3424e1087669b3df92451af2ab SHA512 6cd93cd10dd0c6338909ce381a1b8bb208c0351521131b0bab488e6a6ef6081e279ef0ce47653d88ceecfeaf3128031bce22fbcbc926f9bae381cfea65db655b WHIRLPOOL 9a92c8bbf38e8512308625e1107e9af69ccff2f2c748bd5d49997feb63ec76663a31ad25fbefed62f2e970563c38df13bf378c3dff7a91a7d232958058cb1d64
+DIST cacti-spine-1.0.4.tar.gz 800817 SHA256 0c1640728834c0022712d991cc98d5fade7ad91ff80a4409f26e40236d96d187 SHA512 0546edded564a87696b880166819a1d72d0c02e9e94630997fe6b0f0b183c93172cb43d6f6c73f8156e7b9d13878dc105487da24ecce08f0004284d1000701ac WHIRLPOOL cb0c0df93f801dd0f65d2d438c6cc070cdcacf2a52afa9162cb99b50ea2981ebd45fbdf2c833329e562c2da967e6115874984372c63f989ed5040e39b91a470b
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.0.4.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.0.4.ebuild
new file mode 100644
index 000000000000..34727025866f
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-1.0.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="http://cacti.net/spine_info.php"
+SRC_URI="http://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+CDEPEND="
+ dev-libs/openssl:*
+ net-analyzer/net-snmp
+ virtual/mysql
+"
+DEPEND="
+ ${CDEPEND}
+ sys-apps/help2man
+"
+RDEPEND="
+ ${CDEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.8d-ping.patch
+ "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
+)
+
+src_prepare() {
+ default
+
+ AT_M4DIR="config" eautoreconf
+}
+
+src_install() {
+ dosbin spine
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+ dodoc ChangeLog
+}