summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/cbm/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/cbm/files')
-rw-r--r--net-analyzer/cbm/files/cbm-0.1-gcc-4.3.patch10
-rw-r--r--net-analyzer/cbm/files/cbm-0.1-gcc-4.7.patch10
-rw-r--r--net-analyzer/cbm/files/cbm-0.1-headers-status-line.patch55
-rw-r--r--net-analyzer/cbm/files/cbm-0.1-tinfo.patch19
4 files changed, 94 insertions, 0 deletions
diff --git a/net-analyzer/cbm/files/cbm-0.1-gcc-4.3.patch b/net-analyzer/cbm/files/cbm-0.1-gcc-4.3.patch
new file mode 100644
index 000000000000..ae9b58f6e99b
--- /dev/null
+++ b/net-analyzer/cbm/files/cbm-0.1-gcc-4.3.patch
@@ -0,0 +1,10 @@
+--- a/src/statistics.hpp
++++ b/src/statistics.hpp
+@@ -3,6 +3,7 @@
+
+ #include <list>
+ #include <string>
++#include <sys/time.h>
+
+ namespace statistics {
+
diff --git a/net-analyzer/cbm/files/cbm-0.1-gcc-4.7.patch b/net-analyzer/cbm/files/cbm-0.1-gcc-4.7.patch
new file mode 100644
index 000000000000..94b50a6877f7
--- /dev/null
+++ b/net-analyzer/cbm/files/cbm-0.1-gcc-4.7.patch
@@ -0,0 +1,10 @@
+--- a/src/cbm.cpp
++++ b/src/cbm.cpp
+@@ -18,6 +18,7 @@
+ #include <sys/socket.h>
+ #include <arpa/inet.h>
+ #include <net/if.h>
++#include <unistd.h>
+
+ // Externs
+ extern int optind, opterr, optopt;
diff --git a/net-analyzer/cbm/files/cbm-0.1-headers-status-line.patch b/net-analyzer/cbm/files/cbm-0.1-headers-status-line.patch
new file mode 100644
index 000000000000..4b09bbb69793
--- /dev/null
+++ b/net-analyzer/cbm/files/cbm-0.1-headers-status-line.patch
@@ -0,0 +1,55 @@
+From bdc4f02a6d7fb1416f36aef89af4592c691576d8 Mon Sep 17 00:00:00 2001
+From: Jari Aalto <jari.aalto@cante.net>
+Date: Mon, 19 Sep 2011 14:27:04 +0300
+Subject: [PATCH] [fix] Headers and status line don't display by Paul Martin
+ <pm@debian.org>
+Organization: Private
+Content-Type: text/plain; charset="utf-8"
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Jari Aalto <jari.aalto@cante.net>
+---
+ src/cbm.cpp | 9 ++++++++-
+ src/widgets/Window.cpp | 2 +-
+ 2 files changed, 9 insertions(+), 2 deletions(-)
+
+index 74282e2..0197443 100644
+--- a/src/cbm.cpp
++++ b/src/cbm.cpp
+@@ -156,13 +156,20 @@ int main(int argc, char **argv) {
+ interfaceTable.setColumns(4);
+ interfaceTable.setActiveStyle(A_BOLD);
+ interfaceTable.setActiveRow(1);
++ // Position the interface table
++ interfaceTable.setPosition(2, 2);
++ interfaceTable.setSize(screen.getWidth() - 4,
++ 8); // TODO
+
+ // Create the detail table
+ VerticalTable detailTable(screen);
+ detailTable.setColumns(2);
+ detailTable.setRows(2);
+ detailTable.setActiveRow(-1);
+-
++ // Position the detail table
++ detailTable.setPosition(2, 12); // TODO
++ detailTable.setSize(screen.getWidth() - 4, 10); // TODO
++
+ // Populate the detail table
+ detailTable.setText (0, 0, "Interface");
+ detailTable.setStyle(0, 0, COLOR_PAIR(COLOR_HEADING) | A_BOLD);
+index 322cb9b..572eef7 100644
+--- a/src/widgets/Window.cpp
++++ b/src/widgets/Window.cpp
+@@ -14,7 +14,7 @@ Window::~Window() {
+ }
+
+ void Window::setPosition(unsigned x, unsigned y) {
+- mvwin((WINDOW*) win_, y, x);
++ mvderwin((WINDOW*) win_, y, x);
+ }
+
+ void Window::setSize(unsigned width, unsigned height) {
+--
+1.7.5.4
+
diff --git a/net-analyzer/cbm/files/cbm-0.1-tinfo.patch b/net-analyzer/cbm/files/cbm-0.1-tinfo.patch
new file mode 100644
index 000000000000..955d762214c4
--- /dev/null
+++ b/net-analyzer/cbm/files/cbm-0.1-tinfo.patch
@@ -0,0 +1,19 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -3,4 +3,4 @@
+ cbm_SOURCES = cbm.cpp \
+ ErrnoError.hpp \
+ statistics.cpp statistics.hpp
+-cbm_LDADD = -lncurses widgets/libwidgets.la
++cbm_LDADD = $(ncurses_LIBS) widgets/libwidgets.la
+--- a/configure.ac
++++ b/configure.ac
+@@ -18,6 +18,8 @@
+
+ # Checks for libraries.
+
++PKG_CHECK_MODULES(ncurses,ncurses)
++
+ # Checks for header files.
+
+ # Checks for typedefs, structures, and compiler characteristics.