summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 03:03:50 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:54:54 +0100
commit364a8e35a524db25c4e2ccaea41b7434e693876f (patch)
tree784af73aba47174bb46f9b25258a45595b98c7af /net-analyzer/cryptcat
parentnet-analyzer/cnet: port to EAPI 7, eutils--, multilib-- (diff)
downloadgentoo-364a8e35a524db25c4e2ccaea41b7434e693876f.tar.gz
gentoo-364a8e35a524db25c4e2ccaea41b7434e693876f.tar.bz2
gentoo-364a8e35a524db25c4e2ccaea41b7434e693876f.zip
net-analyzer/cryptcat: EAPI 7, eutils--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/cryptcat')
-rw-r--r--net-analyzer/cryptcat/cryptcat-1.2.1-r2.ebuild16
-rw-r--r--net-analyzer/cryptcat/files/cryptcat-1.2.1-build.patch4
2 files changed, 12 insertions, 8 deletions
diff --git a/net-analyzer/cryptcat/cryptcat-1.2.1-r2.ebuild b/net-analyzer/cryptcat/cryptcat-1.2.1-r2.ebuild
index 0c94c1940d9e..a3d959ea9cbe 100644
--- a/net-analyzer/cryptcat/cryptcat-1.2.1-r2.ebuild
+++ b/net-analyzer/cryptcat/cryptcat-1.2.1-r2.ebuild
@@ -1,22 +1,26 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="netcat clone extended with twofish encryption"
HOMEPAGE="http://cryptcat.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${PN}-unix-${PV}.tar"
+S="${WORKDIR}"/unix
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
-S=${WORKDIR}/unix
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-misc.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${P}-build.patch
- epatch "${FILESDIR}"/${P}-misc.patch
+ default
tc-export CC CXX
}
diff --git a/net-analyzer/cryptcat/files/cryptcat-1.2.1-build.patch b/net-analyzer/cryptcat/files/cryptcat-1.2.1-build.patch
index 17ec33489c89..0b9c62b597f0 100644
--- a/net-analyzer/cryptcat/files/cryptcat-1.2.1-build.patch
+++ b/net-analyzer/cryptcat/files/cryptcat-1.2.1-build.patch
@@ -1,5 +1,5 @@
---- a/unix/Makefile
-+++ b/unix/Makefile
+--- a/Makefile
++++ b/Makefile
@@ -10,16 +10,14 @@
# debugging
# DFLAGS = -DTEST -DDEBUG