summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-12-02 12:06:29 +0100
committerJeroen Roovers <jer@gentoo.org>2017-12-02 12:06:29 +0100
commit7ee896f95444c6422cc351123a14b221fa94e462 (patch)
treeb5d8796cbbf5a66965fb715d150d84dfc186050f /net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r4.ebuild
parentnet-libs/libflowmanager: Add include (bug #639456). (diff)
downloadgentoo-7ee896f95444c6422cc351123a14b221fa94e462.tar.gz
gentoo-7ee896f95444c6422cc351123a14b221fa94e462.tar.bz2
gentoo-7ee896f95444c6422cc351123a14b221fa94e462.zip
net-analyzer/dhcp_probe: EAPI bump.
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r4.ebuild')
-rw-r--r--net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r4.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r4.ebuild b/net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r4.ebuild
new file mode 100644
index 000000000000..9a97d906c0a5
--- /dev/null
+++ b/net-analyzer/dhcp_probe/dhcp_probe-1.3.0-r4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic
+
+DESCRIPTION="dhcp_probe attempts to discover DHCP and BootP servers on a directly-attached Ethernet network"
+HOMEPAGE="http://www.net.princeton.edu/software/dhcp_probe/"
+SRC_URI="http://www.net.princeton.edu/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="
+ net-libs/libpcap
+ >=net-libs/libnet-1.1.2.1-r2
+"
+RDEPEND="${DEPEND}"
+DOCS=(
+ "${FILESDIR}"/${PN}_mail
+ AUTHORS
+ ChangeLog
+ NEWS
+ README
+ TODO
+ extras/dhcp_probe.cf.sample
+)
+PATCHES=(
+ "${FILESDIR}"/${PV}/01_dhcp_probe.5.patch
+ "${FILESDIR}"/${PV}/02_dhcp_probe.8.patch
+ "${FILESDIR}"/${PV}/03_implicit_point_conv_bootp.c.patch
+ "${FILESDIR}"/${PV}/04_linux_32_or_64bits.patch
+ "${FILESDIR}"/${PV}/05-cleanup.patch
+ "${FILESDIR}"/${PV}/06-return.patch
+ "${FILESDIR}"/${PV}/07-comment.patch
+ "${FILESDIR}"/${PV}/08-man8.patch
+)
+
+src_configure() {
+ use amd64 && append-flags -D__ARCH__=64
+ STRIP=true econf
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+}