summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-20 00:32:23 +0000
committerSam James <sam@gentoo.org>2022-03-20 00:32:23 +0000
commit74452af4da8702701ecc45b5f46ae200bfab233d (patch)
treed26560ab44918f1380a4e4ffd09d843d1f9c6415 /net-analyzer/ethloop/ethloop-10-r4.ebuild
parentnet-wireless/rfkill: [QA] fix tc-get* quoting (diff)
downloadgentoo-74452af4da8702701ecc45b5f46ae200bfab233d.tar.gz
gentoo-74452af4da8702701ecc45b5f46ae200bfab233d.tar.bz2
gentoo-74452af4da8702701ecc45b5f46ae200bfab233d.zip
net-analyzer/ethloop: [QA] fix tc-get* quoting
This can cause build problems for e.g. 32-bit (gcc -m32 ...) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/ethloop/ethloop-10-r4.ebuild')
-rw-r--r--net-analyzer/ethloop/ethloop-10-r4.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/net-analyzer/ethloop/ethloop-10-r4.ebuild b/net-analyzer/ethloop/ethloop-10-r4.ebuild
index 17108d444276..dc5653f727a8 100644
--- a/net-analyzer/ethloop/ethloop-10-r4.ebuild
+++ b/net-analyzer/ethloop/ethloop-10-r4.ebuild
@@ -1,25 +1,26 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit toolchain-funcs
DESCRIPTION="Local simulator for testing Linux QoS disciplines"
HOMEPAGE="http://luxik.cdi.cz/~devik/qos/ethloop/"
SRC_URI="http://luxik.cdi.cz/~devik/qos/${PN}/${PN}${PV}.tgz"
+S="${WORKDIR}"/${PN}
LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="~amd64 ~ppc x86"
RESTRICT="mirror bindist"
-S=${WORKDIR}/${PN}
PATCHES=(
"${FILESDIR}"/${P}-misc.patch
)
src_compile() {
- emake CC=$(tc-getCC) CFLAGS="${CFLAGS}"
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
}
src_install() {