summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2016-02-03 14:20:30 +0100
committerHanno <hanno@gentoo.org>2016-02-03 14:20:30 +0100
commit7ae2408128f94c0094f715858e44c11ac6d4cbcf (patch)
tree08c7168b447f921ebfba9e5db40b9bc7bd03a592 /net-analyzer/greenbone-security-assistant
parentdev-lang/moarvm: Bump (diff)
downloadgentoo-7ae2408128f94c0094f715858e44c11ac6d4cbcf.tar.gz
gentoo-7ae2408128f94c0094f715858e44c11ac6d4cbcf.tar.bz2
gentoo-7ae2408128f94c0094f715858e44c11ac6d4cbcf.zip
net-analyzer/greenbone-security-assistant: Security bump, fix #573770
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-analyzer/greenbone-security-assistant')
-rw-r--r--net-analyzer/greenbone-security-assistant/Manifest1
-rw-r--r--net-analyzer/greenbone-security-assistant/greenbone-security-assistant-6.0.9.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-analyzer/greenbone-security-assistant/Manifest b/net-analyzer/greenbone-security-assistant/Manifest
index 60bd670f5103..cc88ae75f82b 100644
--- a/net-analyzer/greenbone-security-assistant/Manifest
+++ b/net-analyzer/greenbone-security-assistant/Manifest
@@ -1 +1,2 @@
DIST greenbone-security-assistant-6.0.8.tar.gz 1475498 SHA256 1dc23cc24dcd7adc84aaed218e0d9651e032b930ab897c571bf16eb0b155b1ff SHA512 4126e05fc9c7c3272200a070d849fb21c680f49390d5305dc433aa16bf4365525a2c6047575fc11ca53668f87ce5d2a1aef5e63e782cea9d403129ab86aafa8d WHIRLPOOL 91f38c495d99a1c54132e276c321f536abe2ca9a08d9caba716457d2ffb7b63025bb687ff1e6640912d41aed7b39875f1e5a4d2acba4ab7d48248cdf373414fc
+DIST greenbone-security-assistant-6.0.9.tar.gz 1476238 SHA256 bc3dead8e3c24ad906466c208aad1c48262dc912a941b255427f72b0932595e2 SHA512 4afb50f044b6853181c3c3e6466e7329915356bbcccecf98b89d9dc39a193392f45850f9073ac055ec826753af78e8a6368e7f9ac52734a3b5e254d124180d68 WHIRLPOOL d53d8b7e9cfccf5309d300e7ae806cca7586a1056644d582c4da1afa3cc04a6cb87426aa89005c5ef536b764868a5d0febb67d90042e1cc800ae892fcaeb2cca
diff --git a/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-6.0.9.ebuild b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-6.0.9.ebuild
new file mode 100644
index 000000000000..77cbf92da765
--- /dev/null
+++ b/net-analyzer/greenbone-security-assistant/greenbone-security-assistant-6.0.9.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils systemd
+
+MY_PN=gsad
+
+DL_ID=2287
+
+DESCRIPTION="Greenbone Security Assistant for openvas"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/${DL_ID}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2+ BSD MIT"
+KEYWORDS=" ~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libgcrypt:0
+ dev-libs/libxslt
+ >=net-analyzer/openvas-libraries-8.0.3
+ net-libs/libmicrohttpd[messages]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.0.3-run.patch
+ )
+
+S="${WORKDIR}"/${P}
+
+src_prepare() {
+ sed \
+ -e '/^install.*OPENVAS_CACHE_DIR.*/d' \
+ -i CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLOCALSTATEDIR="${EPREFIX}/var"
+ -DSYSCONFDIR="${EPREFIX}/etc"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newinitd "${FILESDIR}"/${MY_PN}.init ${MY_PN}
+
+ insinto /etc/openvas
+ doins "${FILESDIR}"/${MY_PN}-daemon.conf
+ dosym ../openvas/${MY_PN}-daemon.conf /etc/conf.d/${MY_PN}
+
+ insinto /etc/logrotate.d
+ doins "${FILESDIR}"/${MY_PN}.logrotate
+
+ systemd_newtmpfilesd "${FILESDIR}"/${MY_PN}.tmpfiles.d ${MY_PN}.conf
+ systemd_dounit "${FILESDIR}"/${MY_PN}.service
+}