summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHasan ÇALIŞIR <hasan.calisir@psauxit.com>2019-02-07 04:57:45 +0300
committerPatrice Clement <monsieurp@gentoo.org>2019-03-13 15:58:53 +0100
commit257b29c2db97033f98e6a712bab787f569f7ee50 (patch)
tree77e0b8802625440ef88820d5b61046e44925dbc0 /net-analyzer/gvm-tools/gvm-tools-1.4.1.ebuild
parentnet-analyzer/ospd: version bump to 1.3.2. (diff)
downloadgentoo-257b29c2db97033f98e6a712bab787f569f7ee50.tar.gz
gentoo-257b29c2db97033f98e6a712bab787f569f7ee50.tar.bz2
gentoo-257b29c2db97033f98e6a712bab787f569f7ee50.zip
net-analyzer/gvm-tools: new package.
gvm-tools in short is a collection of tools that help with remote controlling a Greenbone Security Manager (GSM) appliance and its underlying Greenbone Vulnerability Manager (GVM). The tools essentially aid accessing the communication protocols GMP (Greenbone Management Protocol) and OSP (Open Scanner Protocol). This package is part of net-analyzer/openvas. This package is replacement of net-analyzer/openvas-cli which is not needed anymore. This package is replacement of net-analyzer/openvas-tools which is not needed anymore. Reported-by: NP-Hardass <np-hardass@gentoo.org> Acked-by: Hasan ÇALIŞIR <hasan.calisir@psauxit.com> Tested-by: Hasan ÇALIŞIR <hasan.calisir@psauxit.com> Signed-off-by: Hasan ÇALIŞIR <hasan.calisir@psauxit.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-analyzer/gvm-tools/gvm-tools-1.4.1.ebuild')
-rw-r--r--net-analyzer/gvm-tools/gvm-tools-1.4.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-analyzer/gvm-tools/gvm-tools-1.4.1.ebuild b/net-analyzer/gvm-tools/gvm-tools-1.4.1.ebuild
new file mode 100644
index 000000000000..98d3f4eb3995
--- /dev/null
+++ b/net-analyzer/gvm-tools/gvm-tools-1.4.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+inherit distutils-r1
+
+DESCRIPTION="A remote security scanner for Linux (OpenVAS-cli)"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="https://github.com/greenbone/gvm-tools/archive/v1.4.1.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pythondialog:0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=net-analyzer/openvas-manager-7.0.3
+ !net-analyzer/openvas-cli"
+
+DEPEND="
+ ${RDEPEND}
+ >=net-analyzer/openvas-libraries-9.0.3"
+
+src_prepare() {
+ distutils-r1_python_prepare_all
+ # Exlude tests & correct FHS/Gentoo policy paths
+ sed -i "s/packages=find_packages(),.*/packages=find_packages(exclude=['tests*', 'docs']),/" "$S"/setup.py || die
+ sed -i -e "s*''*'/usr/share/doc/${P}'*g" "$S"/setup.py || die
+}