summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-07-17 10:56:53 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-07-17 11:02:12 -0500
commit8b834fa574a2595f283a10129173bc297c86b6fa (patch)
tree4671bae30e48875d597aa6118d639415781168ad /net-analyzer/icinga2/icinga2-9999.ebuild
parentnet-wireless/gnuradio: bump (diff)
downloadgentoo-8b834fa574a2595f283a10129173bc297c86b6fa.tar.gz
gentoo-8b834fa574a2595f283a10129173bc297c86b6fa.tar.bz2
gentoo-8b834fa574a2595f283a10129173bc297c86b6fa.zip
net-analyzer/icinga2: 2.9.0 bup
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'net-analyzer/icinga2/icinga2-9999.ebuild')
-rw-r--r--net-analyzer/icinga2/icinga2-9999.ebuild21
1 files changed, 4 insertions, 17 deletions
diff --git a/net-analyzer/icinga2/icinga2-9999.ebuild b/net-analyzer/icinga2/icinga2-9999.ebuild
index ebdd790be879..3085070c612b 100644
--- a/net-analyzer/icinga2/icinga2-9999.ebuild
+++ b/net-analyzer/icinga2/icinga2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,7 +18,7 @@ HOMEPAGE="http://icinga.org/icinga2"
LICENSE="GPL-2"
SLOT="0"
-IUSE="+mysql postgres classicui console libressl lto mail minimal nano-syntax +plugins studio +vim-syntax"
+IUSE="+mysql postgres classicui console libressl lto mail minimal nano-syntax +plugins systemd +vim-syntax"
WX_GTK_VER="3.0"
CDEPEND="
@@ -41,8 +41,7 @@ RDEPEND="
net-analyzer/nagios-plugins
) )
mail? ( virtual/mailx )
- classicui? ( net-analyzer/icinga[web] )
- studio? ( x11-libs/wxGTK:3.0 )"
+ classicui? ( net-analyzer/icinga[web] )"
REQUIRED_USE="!minimal? ( || ( mysql postgres ) )"
@@ -50,9 +49,6 @@ want_apache2
pkg_setup() {
depend.apache_pkg_setup
- if use studio ; then
- setup-wxwidgets
- fi
enewgroup icinga
enewgroup icingacmd
enewgroup nagios # for plugins
@@ -74,6 +70,7 @@ src_configure() {
-DICINGA2_GROUP=icingacmd
-DICINGA2_COMMAND_GROUP=icingacmd
-DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=yes
+ -DUSE_SYSTEMD=$(usex systemd ON OFF)
-DLOGROTATE_HAS_SU=ON
)
# default to off if minimal, allow the flags to be set otherwise
@@ -98,16 +95,6 @@ src_configure() {
-DICINGA2_LTO_BUILD=OFF
)
fi
- # STUDIO
- if use studio; then
- mycmakeargs+=(
- -DICINGA2_WITH_STUDIO=ON
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_STUDIO=OFF
- )
- fi
cmake-utils_src_configure
}