summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-31 11:49:14 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-31 11:55:27 -0500
commitba9c60694d004d01b0426c8d3d33cb7551054acd (patch)
tree88ef420593456034ee33f424530f06bccf0a1c69 /net-analyzer/icinga2/icinga2-9999.ebuild
parentsys-process/cronutils: remove old google-code upstream metadata (diff)
downloadgentoo-ba9c60694d004d01b0426c8d3d33cb7551054acd.tar.gz
gentoo-ba9c60694d004d01b0426c8d3d33cb7551054acd.tar.bz2
gentoo-ba9c60694d004d01b0426c8d3d33cb7551054acd.zip
net-analyzer/icinga2: fixing ownership of the config directory
Package-Manager: Portage-2.3.6, Repoman-2.3.3 RepoMan-Options: --force
Diffstat (limited to 'net-analyzer/icinga2/icinga2-9999.ebuild')
-rw-r--r--net-analyzer/icinga2/icinga2-9999.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/net-analyzer/icinga2/icinga2-9999.ebuild b/net-analyzer/icinga2/icinga2-9999.ebuild
index af171a68b517..644d451cfc6f 100644
--- a/net-analyzer/icinga2/icinga2-9999.ebuild
+++ b/net-analyzer/icinga2/icinga2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -24,7 +24,7 @@ WX_GTK_VER="3.0"
CDEPEND="
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
- >=dev-libs/boost-1.41
+ >=dev-libs/boost-1.58-r1
console? ( dev-libs/libedit )
mysql? ( virtual/mysql )
postgres? ( dev-db/postgresql:= )"
@@ -69,6 +69,7 @@ src_configure() {
-DCMAKE_INSTALL_SYSCONFDIR=/etc
-DCMAKE_INSTALL_LOCALSTATEDIR=/var
-DICINGA2_SYSCONFIGFILE=/etc/conf.d/icinga2
+ -DICINGA2_PLUGINDIR="/usr/$(get_libdir)/nagios/plugins"
-DICINGA2_USER=icinga
-DICINGA2_GROUP=icingacmd
-DICINGA2_COMMAND_USER=icinga
@@ -121,7 +122,6 @@ src_install() {
einstalldocs
newinitd "${FILESDIR}"/icinga2.initd icinga2
- newconfd "${FILESDIR}"/icinga2.confd icinga2
if use mysql ; then
docinto schema
@@ -144,7 +144,8 @@ src_install() {
rm -r "${D}/var/run" || die "failed to remove /var/run"
rm -r "${D}/var/cache" || die "failed to remove /var/cache"
- fowners icinga:icinga /etc/icinga2
+ fowners root:icinga /etc/icinga2
+ fperms 0750 /etc/icinga2
fowners icinga:icinga /var/lib/icinga2
fowners icinga:icinga /var/spool/icinga2
fowners -R icinga:icingacmd /var/lib/icinga2/api