summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-04-19 10:58:56 +0200
committerJeroen Roovers <jer@gentoo.org>2020-04-19 11:19:47 +0200
commitc8ed469e826d51057421755ae28601284da03713 (patch)
treeecea9e520d3fbd5e78e5928483b997bb5f8ba05f /net-analyzer/ike-scan/ike-scan-1.9.4.ebuild
parentdev-python/gnome-python-desktop-base: Remove last-rited pkg (diff)
downloadgentoo-c8ed469e826d51057421755ae28601284da03713.tar.gz
gentoo-c8ed469e826d51057421755ae28601284da03713.tar.bz2
gentoo-c8ed469e826d51057421755ae28601284da03713.zip
net-analyzer/ike-scan: Version 1.9.4
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/ike-scan/ike-scan-1.9.4.ebuild')
-rw-r--r--net-analyzer/ike-scan/ike-scan-1.9.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-analyzer/ike-scan/ike-scan-1.9.4.ebuild b/net-analyzer/ike-scan/ike-scan-1.9.4.ebuild
new file mode 100644
index 000000000000..8fbaa0ed31e5
--- /dev/null
+++ b/net-analyzer/ike-scan/ike-scan-1.9.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A utility for finding, fingerprinting and testing IKE VPN servers"
+HOMEPAGE="https://github.com/royhills/ike-scan/"
+SRC_URI="https://github.com/royhills/ike-scan/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="libressl ssl"
+
+DEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_prepare() {
+ # Fix buffer overflow, bug #277556
+ sed \
+ -e "/MAXLINE/s:255:511:g" \
+ -i ike-scan.h || die
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with ssl openssl)
+}
+
+src_install() {
+ default
+ dodoc udp-backoff-fingerprinting-paper.txt
+}