summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-04-19 11:19:30 +0200
committerJeroen Roovers <jer@gentoo.org>2020-04-19 11:19:48 +0200
commit4143943a909e4ef0a97d1253c11233b49ffc824c (patch)
tree0b3439ef38cf9bc7ae0b668d4958c12c92498be8 /net-analyzer/ike-scan
parentnet-analyzer/ike-scan: Version 1.9.4 (diff)
downloadgentoo-4143943a909e4ef0a97d1253c11233b49ffc824c.tar.gz
gentoo-4143943a909e4ef0a97d1253c11233b49ffc824c.tar.bz2
gentoo-4143943a909e4ef0a97d1253c11233b49ffc824c.zip
net-analyzer/ike-scan: Add live ebuild
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/ike-scan')
-rw-r--r--net-analyzer/ike-scan/ike-scan-99999.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-analyzer/ike-scan/ike-scan-99999.ebuild b/net-analyzer/ike-scan/ike-scan-99999.ebuild
new file mode 100644
index 000000000000..1e9a5ce43bb9
--- /dev/null
+++ b/net-analyzer/ike-scan/ike-scan-99999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools git-r3
+
+DESCRIPTION="A utility for finding, fingerprinting and testing IKE VPN servers"
+HOMEPAGE="https://github.com/royhills/ike-scan/"
+EGIT_REPO_URI="https://github.com/royhills/ike-scan"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="libressl ssl"
+KEYWORDS=""
+
+DEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_prepare() {
+ # Fix buffer overflow, bug #277556
+ sed \
+ -e "/MAXLINE/s:255:511:g" \
+ -i ike-scan.h || die
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with ssl openssl)
+}
+
+src_install() {
+ default
+ dodoc udp-backoff-fingerprinting-paper.txt
+}