summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-01-18 18:35:31 +0100
committerDavid Seifert <soap@gentoo.org>2020-01-18 18:35:31 +0100
commit76d52db8378f0c3ed938642f3ef957ca0faafe8d (patch)
treedd261807232b75422039f839df8d79e344956483 /net-analyzer/ippl/files
parentnet-analyzer/ippl: Remove old (diff)
downloadgentoo-76d52db8378f0c3ed938642f3ef957ca0faafe8d.tar.gz
gentoo-76d52db8378f0c3ed938642f3ef957ca0faafe8d.tar.bz2
gentoo-76d52db8378f0c3ed938642f3ef957ca0faafe8d.zip
net-analyzer/ippl: Port to EAPI 7
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-analyzer/ippl/files')
-rw-r--r--net-analyzer/ippl/files/ippl-1.4.14-fix-build-system.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-analyzer/ippl/files/ippl-1.4.14-fix-build-system.patch b/net-analyzer/ippl/files/ippl-1.4.14-fix-build-system.patch
new file mode 100644
index 000000000000..c6c65cb14d50
--- /dev/null
+++ b/net-analyzer/ippl/files/ippl-1.4.14-fix-build-system.patch
@@ -0,0 +1,44 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -11,10 +11,10 @@
+ all: binary docs
+
+ binary: Makefile Source/Makefile
+- @cd Source && make && cd ..
++ @cd Source && $(MAKE) && cd ..
+
+ docs:
+- @cd Docs && make && cd ..
++ @cd Docs && $(MAKE) && cd ..
+
+ install: all
+ $(INSTALL) -d -m 755 $(SBINDIR)
+@@ -29,7 +29,7 @@
+ $(INSTALL) -m 644 Docs/ippl.conf.5 $(MANDIR)/man5/ippl.conf.5
+
+ clean:
+- @cd Source && make clean && cd .. && cd Docs && make clean && cd ..
++ @cd Source && $(MAKE) clean && cd .. && cd Docs && $(MAKE) clean && cd ..
+
+ distclean: clean
+ $(RM) *~ Makefile.common Makefile Source/Makefile Docs/Makefile build-stamp install-stamp
+--- a/Source/Makefile.in
++++ b/Source/Makefile.in
+@@ -10,7 +10,7 @@
+ CC=@CC@
+ CFLAGS=@CFLAGS@
+ WARNINGS=-Wall@PEDANTIC@
+-LDFLAGS=
++LDFLAGS=@LDFLAGS@
+
+ SRCS= main.c \
+ configuration.c \
+@@ -49,7 +49,7 @@
+ y.tab.c: ippl.y Makefile ../Makefile.common
+ $(YACC) -d $<
+
+-lex.yy.c: ippl.l Makefile ../Makefile.common
++lex.yy.c: ippl.l y.tab.c Makefile ../Makefile.common
+ $(LEX) $<
+
+ clean: