summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/jnettop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/jnettop')
-rw-r--r--net-analyzer/jnettop/Manifest1
-rw-r--r--net-analyzer/jnettop/files/jnettop-0.13.0-asneeded.patch12
-rw-r--r--net-analyzer/jnettop/files/jnettop-0.13.0-tinfo.patch11
-rw-r--r--net-analyzer/jnettop/jnettop-0.13.0-r1.ebuild47
-rw-r--r--net-analyzer/jnettop/metadata.xml6
5 files changed, 77 insertions, 0 deletions
diff --git a/net-analyzer/jnettop/Manifest b/net-analyzer/jnettop/Manifest
new file mode 100644
index 000000000000..ab6b97f02ea8
--- /dev/null
+++ b/net-analyzer/jnettop/Manifest
@@ -0,0 +1 @@
+DIST jnettop-0.13.0.tar.gz 131009 SHA256 e987a1a9325595c8a0543ab61cf3b6d781b4faf72dd0e0e0c70b2cc2ceb5a5a0 SHA512 304293cd011ce8556aabf69e91b2e831ac61aa43016bb5b616d24b45805315a815dfba37dfe9f7cd3c637931043d4123b2f46a7637ba1a0b9d30267fe6dcb051 WHIRLPOOL 9e4c2226f40b6ee95905e51f0f4d2b70e4a0aeea40ca9fbb3cc0ba696c673d4fb95aecbe5757857e49533b7628bd8cdf5c27cc568fbcd34167fe40fca52b961f
diff --git a/net-analyzer/jnettop/files/jnettop-0.13.0-asneeded.patch b/net-analyzer/jnettop/files/jnettop-0.13.0-asneeded.patch
new file mode 100644
index 000000000000..8a43240bb0de
--- /dev/null
+++ b/net-analyzer/jnettop/files/jnettop-0.13.0-asneeded.patch
@@ -0,0 +1,12 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,8 +1,7 @@
+
+
+ INCLUDES = -I$(top_srcdir)/include @GLIB_CFLAGS@
+-AM_LDFLAGS = @GLIB_LIBS@ @NSL_LIBS@ @SOCKET_LIBS@
+-CFLAGS = -g -O0
++jnettop_LDADD = @GLIB_LIBS@ @NSL_LIBS@ @SOCKET_LIBS@
+
+ man_MANS = jnettop.8
+
diff --git a/net-analyzer/jnettop/files/jnettop-0.13.0-tinfo.patch b/net-analyzer/jnettop/files/jnettop-0.13.0-tinfo.patch
new file mode 100644
index 000000000000..958685cb5c12
--- /dev/null
+++ b/net-analyzer/jnettop/files/jnettop-0.13.0-tinfo.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -15,6 +15,8 @@
+ AC_HEADER_STDC
+ AC_CHECK_HEADERS([arpa/inet.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h sys/sockio.h])
+
++PKG_CHECK_MODULES(ncurses,ncurses,[LIBS="$LIBS $ncurses_LIBS"],)
++
+ # with definitions
+ AC_ARG_WITH([ncurses],
+ AC_HELP_STRING([--without-ncurses], [don't use ncurses, default is YES when available]),
diff --git a/net-analyzer/jnettop/jnettop-0.13.0-r1.ebuild b/net-analyzer/jnettop/jnettop-0.13.0-r1.ebuild
new file mode 100644
index 000000000000..e015ba9407d6
--- /dev/null
+++ b/net-analyzer/jnettop/jnettop-0.13.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="A top like console network traffic visualiser"
+HOMEPAGE="http://jnettop.kubs.info/"
+SRC_URI="http://jnettop.kubs.info/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="berkdb ncurses syslog"
+
+RDEPEND="
+ net-libs/libpcap
+ >=dev-libs/glib-2.0.1
+ berkdb? ( =sys-libs/db-4* )
+ ncurses? ( sys-libs/ncurses )
+ syslog? ( virtual/logger )
+"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${P}-asneeded.patch" \
+ "${FILESDIR}/${P}-tinfo.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with ncurses) \
+ $(use_with berkdb db4) \
+ $(use_with syslog)
+}
+
+src_install() {
+ default
+ newdoc .${PN} ${PN}.dotfile
+}
diff --git a/net-analyzer/jnettop/metadata.xml b/net-analyzer/jnettop/metadata.xml
new file mode 100644
index 000000000000..07768d7e05b1
--- /dev/null
+++ b/net-analyzer/jnettop/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<longdescription>A top like console network traffic visualiser</longdescription>
+</pkgmetadata>