summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2016-12-22 23:56:57 +0000
committerMichael Orlitzky <mjo@gentoo.org>2016-12-23 13:50:58 -0500
commit97acecd2a67cc1a1da1c29ea98fd6e9592acc6b8 (patch)
tree09d06c30ebac696861beb424b7ec6b510d77e1ed /net-analyzer/monitoring-plugins
parentkde-apps/kross-interpreters: Drop slot 4 (diff)
downloadgentoo-97acecd2a67cc1a1da1c29ea98fd6e9592acc6b8.tar.gz
gentoo-97acecd2a67cc1a1da1c29ea98fd6e9592acc6b8.tar.bz2
gentoo-97acecd2a67cc1a1da1c29ea98fd6e9592acc6b8.zip
net-analyzer/monitoring-plugins: bump to 2.2
Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'net-analyzer/monitoring-plugins')
-rw-r--r--net-analyzer/monitoring-plugins/Manifest1
-rw-r--r--net-analyzer/monitoring-plugins/monitoring-plugins-2.2.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/net-analyzer/monitoring-plugins/Manifest b/net-analyzer/monitoring-plugins/Manifest
index 46c48c39d240..53329e6b4f03 100644
--- a/net-analyzer/monitoring-plugins/Manifest
+++ b/net-analyzer/monitoring-plugins/Manifest
@@ -1 +1,2 @@
DIST monitoring-plugins-2.1.2.tar.gz 2613060 SHA256 76c6b58f0867ab7b6c8c86c7e94fcce7183618f6daab63488990d0355f5600aa SHA512 845eb7636691aa5402119384c3d4256969e959fbc29ef5257c24fc4c21536cad3dade30747f36c9ad998cb37df0f325df66ea679d3d5b96c2993b59a9a325fed WHIRLPOOL aea22e1a3d3c7622b4645118cf8b5d499882bd30b6af8bdd81287fb99fe42bff7f906b54fda411ac2c33ff6e42872a6ea6af4dcd7611bdc95d308c0fcd954e43
+DIST monitoring-plugins-2.2.tar.gz 2461548 SHA256 296a538f00a9cbef7f528ff2d43af357a44b384dc98a32389a675b62a6dd3665 SHA512 5f8cfa132891d6d96e69bee3f2c26f7d4546f572be6a18f25ea5d9069f162cb2e424361289a5c26bec60d7b63d28a269437fd6f25645903a1c142fdcbbf77f27 WHIRLPOOL 5ca16cbc63cbbe3472f82b87b2c4111df4877bc33b0a9bf638507aaf8020194adc6e8244c5a002ae636121ae58d7a112cb2c5cba6e384c136e5636bbfc4a6141
diff --git a/net-analyzer/monitoring-plugins/monitoring-plugins-2.2.ebuild b/net-analyzer/monitoring-plugins/monitoring-plugins-2.2.ebuild
new file mode 100644
index 000000000000..8e3cd459b97e
--- /dev/null
+++ b/net-analyzer/monitoring-plugins/monitoring-plugins-2.2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils flag-o-matic multilib user
+
+DESCRIPTION="50+ standard plugins for Icinga, Naemon, Nagios, Shinken, Sensu"
+HOMEPAGE="https://www.monitoring-plugins.org/"
+SRC_URI="https://www.monitoring-plugins.org/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="gnutls ipv6 ldap libressl mysql dns fping game postgres samba snmp ssh +ssl"
+
+# Most of the plugins use automagic dependencies, i.e. the plugin will
+# get built if the binary it uses is installed. For example, check_snmp
+# will be built only if snmpget from net-analyzer/net-snmp[-minimal] is
+# installed. End result: most of our runtime dependencies are required
+# at build time as well.
+#
+# REAL_DEPEND contains the dependencies that are actually needed to
+# build. DEPEND contains those plus the automagic dependencies.
+#
+REAL_DEPEND="dev-lang/perl
+ ldap? ( net-nds/openldap )
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql:= )
+ ssl? (
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ gnutls? ( net-libs/gnutls )
+ )"
+
+DEPEND="${REAL_DEPEND}
+ dns? ( net-dns/bind-tools )
+ game? ( games-util/qstat )
+ fping? ( net-analyzer/fping )
+ samba? ( net-fs/samba )
+ ssh? ( net-misc/openssh )
+ snmp? ( dev-perl/Net-SNMP
+ net-analyzer/net-snmp[-minimal] )"
+
+# Basically everything collides with nagios-plugins.
+RDEPEND="${DEPEND}
+ !net-analyzer/nagios-plugins"
+
+# At least one test is interactive.
+RESTRICT="test"
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+
+ # Use an array to prevent econf from mangling the ping args.
+ local myconf=()
+
+ if use ssl; then
+ myconf+=( $(use_with !gnutls openssl /usr)
+ $(use_with gnutls gnutls /usr) )
+ else
+ myconf+=( --without-openssl )
+ myconf+=( --without-gnutls )
+ fi
+
+ # The autodetection for these two commands can hang if localhost is
+ # down or ICMP traffic is filtered. Bug #468296.
+ myconf+=( --with-ping-command="/bin/ping -n -U -w %d -c %d %s" )
+
+ if use ipv6; then
+ myconf+=( --with-ping6-command="/bin/ping6 -n -U -w %d -c %d %s" )
+ fi
+
+ econf \
+ $(use_with mysql) \
+ $(use_with ipv6) \
+ $(use_with ldap) \
+ $(use_with postgres pgsql /usr) \
+ "${myconf[@]}" \
+ --libexecdir="/usr/$(get_libdir)/nagios/plugins" \
+ --sysconfdir="/etc/nagios"
+}
+
+DOCS=( ACKNOWLEDGEMENTS AUTHORS CODING ChangeLog FAQ \
+ NEWS README REQUIREMENTS SUPPORT THANKS )
+
+pkg_preinst() {
+ enewgroup nagios
+ enewuser nagios -1 /bin/bash /var/nagios/home nagios
+}
+
+pkg_postinst() {
+ elog "This ebuild has a number of USE flags that determine what you"
+ elog "are able to monitor. Depending on what you want to monitor, some"
+ elog "or all of these USE flags need to be set."
+ elog
+ elog "The plugins are installed in ${EROOT%/}/usr/$(get_libdir)/nagios/plugins"
+}