summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/namebench
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/namebench')
-rw-r--r--net-analyzer/namebench/Manifest1
-rw-r--r--net-analyzer/namebench/metadata.xml8
-rw-r--r--net-analyzer/namebench/namebench-1.3.1-r1.ebuild44
3 files changed, 53 insertions, 0 deletions
diff --git a/net-analyzer/namebench/Manifest b/net-analyzer/namebench/Manifest
new file mode 100644
index 000000000000..e7bf7e9a7acf
--- /dev/null
+++ b/net-analyzer/namebench/Manifest
@@ -0,0 +1 @@
+DIST namebench-1.3.1-source.tgz 1118505 SHA256 30ccf9e870c1174c6bf02fca488f62bba280203a0b1e8e4d26f3756e1a5b9425 SHA512 df9d120bf9f0bcbb5e3d41d2257b2c594e99b7e69b33435b59587e99dac6dca29e4ae81f51838946bc1955540109da6296abc6b69d411af2b91e05b58367bb3b WHIRLPOOL 808977fd3e9e2f906350d104be91f0aa80b5df29953a92e00953013b33ce8473fcbc955ceb3d1dc1b71d6491816d6a7e04a0244a12fbd039fd304c7b874cf462
diff --git a/net-analyzer/namebench/metadata.xml b/net-analyzer/namebench/metadata.xml
new file mode 100644
index 000000000000..bdfeb7adc6e5
--- /dev/null
+++ b/net-analyzer/namebench/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <upstream>
+ <remote-id type="google-code">namebench</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/namebench/namebench-1.3.1-r1.ebuild b/net-analyzer/namebench/namebench-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..55f452db8c0a
--- /dev/null
+++ b/net-analyzer/namebench/namebench-1.3.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS Benchmark Utility"
+HOMEPAGE="http://code.google.com/p/namebench/"
+SRC_URI="http://namebench.googlecode.com/files/${P}-source.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X"
+
+# PYTHON_REQ_USE does not support X? ( tk ) syntax yet
+DEPEND="X? ( $(python_gen_cond_dep dev-lang/python:2.7[tk] python2_7) )"
+RDEPEND="${DEPEND}
+ >=dev-python/dnspython-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.6[${PYTHON_USEDEP}]
+ >=dev-python/graphy-1.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.2.1[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-2.1.2[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # don't include bundled libraries
+ export NO_THIRD_PARTY=1
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ #set prefix
+ distutils-r1_python_install --install-data=/usr/share
+}
+
+python_install_all() {
+ dosym ${PN}.py /usr/bin/${PN}
+ distutils-r1_python_install_all
+}