summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-02-07 08:44:43 +0100
committerJeroen Roovers <jer@gentoo.org>2020-02-07 08:45:27 +0100
commit05cde0f7f599843b855db3813f1905a5e60efe80 (patch)
tree8fa51e33edfd514f2250f5572ae43aad47912349 /net-analyzer/nast/nast-0.2.0-r2.ebuild
parentdev-python/python-openid: mark 2.2.5-r1 ~hppa/sparc, bug #700918 (diff)
downloadgentoo-05cde0f7f599843b855db3813f1905a5e60efe80.tar.gz
gentoo-05cde0f7f599843b855db3813f1905a5e60efe80.tar.bz2
gentoo-05cde0f7f599843b855db3813f1905a5e60efe80.zip
net-analyzer/nast: Set CFLAGS=-fcommon
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Closes: https://bugs.gentoo.org/show_bug.cgi?id=708510 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/nast/nast-0.2.0-r2.ebuild')
-rw-r--r--net-analyzer/nast/nast-0.2.0-r2.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/net-analyzer/nast/nast-0.2.0-r2.ebuild b/net-analyzer/nast/nast-0.2.0-r2.ebuild
index 493d47ee9f4b..b2e8f7dd0342 100644
--- a/net-analyzer/nast/nast-0.2.0-r2.ebuild
+++ b/net-analyzer/nast/nast-0.2.0-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="NAST - Network Analyzer Sniffer Tool"
HOMEPAGE="https://sourceforge.net/projects/nast.berlios/"
@@ -30,6 +30,11 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ append-cflags -fcommon
+ default
+}
+
src_compile() {
emake CFLAGS="${CFLAGS}"
}