summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/nb
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/nb')
-rw-r--r--net-analyzer/nb/Manifest2
-rw-r--r--net-analyzer/nb/files/nb-0.8.14-include.patch30
-rw-r--r--net-analyzer/nb/metadata.xml8
-rw-r--r--net-analyzer/nb/nb-0.9.02.ebuild59
-rw-r--r--net-analyzer/nb/nb-0.9.03.ebuild47
5 files changed, 146 insertions, 0 deletions
diff --git a/net-analyzer/nb/Manifest b/net-analyzer/nb/Manifest
new file mode 100644
index 000000000000..c9f62484dbdf
--- /dev/null
+++ b/net-analyzer/nb/Manifest
@@ -0,0 +1,2 @@
+DIST nodebrain-0.9.02.tar.gz 2421175 SHA256 986617d66cca72f01c325953a321e34f28cb80ed105d4ab0e8967e0a328fcf85 SHA512 08ed3e1bd8a8d49bca702ca3b8b1dd72ef9a4bb2dc7b495dd049b6927f4353af6599ad5f8c8135cc11f6ffc68355b79f8782ec0527af27248c755aeaceee51e7 WHIRLPOOL 5c72ebe99e6f7c85870516d6ff41bf700ac05375d4c8bae52b61870737374a4555632b5e7a1b11bfb3ae2ac33c2f44984d3feabc192437f95048a03a4901b558
+DIST nodebrain-0.9.03.tar.gz 2485735 SHA256 e9fce23525da8c6b3e553492b724eb2122faf22aed92ed45b15c6018eb643fef SHA512 bf81ef4be1518b72d8ef0cccf42747cfe2926ed6cecfde97c05c161c2f2d00525d07da2e24b1c05debb84fa6f35dca7d7dbbc3292471f41dd322ea80175fb96c WHIRLPOOL 0ae2c4f8085cbc725662ee758768a7684523350ebe59ab6f50f374c6b5d0b55588697f84bb395bf946eaa3546a052f08f4fa067532b42eafcf84a9a84baecd7c
diff --git a/net-analyzer/nb/files/nb-0.8.14-include.patch b/net-analyzer/nb/files/nb-0.8.14-include.patch
new file mode 100644
index 000000000000..c34965bfe5e5
--- /dev/null
+++ b/net-analyzer/nb/files/nb-0.8.14-include.patch
@@ -0,0 +1,30 @@
+--- a/lib/nbbfi.c
++++ b/lib/nbbfi.c
+@@ -197,6 +197,7 @@
+ *=============================================================================
+ */
+ #include <nb/nbi.h>
++#include <ctype.h> /* isdigit() */
+
+ /**************************************************************************
+ * Index Routines
+--- a/lib/nbkit.c
++++ b/lib/nbkit.c
+@@ -51,6 +51,7 @@
+ #include <pwd.h>
+ #include <errno.h>
+ #include <unistd.h>
++#include <stdlib.h> /* system() */
+
+ static int nbKitUsage(void){
+ printf("Usage:\n");
+--- a/module/webster/nb_webster.c
++++ b/module/webster/nb_webster.c
+@@ -78,6 +78,7 @@
+ */
+ #include "config.h"
+ #include <nb/nb.h>
++#include <ctype.h> /* isalnum() */
+
+ #if defined(WIN32)
+
diff --git a/net-analyzer/nb/metadata.xml b/net-analyzer/nb/metadata.xml
new file mode 100644
index 000000000000..d646f58f7bdc
--- /dev/null
+++ b/net-analyzer/nb/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <upstream>
+ <remote-id type="sourceforge">nodebrain</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/nb/nb-0.9.02.ebuild b/net-analyzer/nb/nb-0.9.02.ebuild
new file mode 100644
index 000000000000..8a5737fad5ad
--- /dev/null
+++ b/net-analyzer/nb/nb-0.9.02.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Nodebrain is a tool to monitor and do event correlation"
+HOMEPAGE="http://nodebrain.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nodebrain/nodebrain-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static-libs"
+
+CDEPEND="dev-libs/libedit"
+DEPEND="
+ ${CDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig
+ sys-apps/texinfo
+"
+RDEPEND="
+ ${CDEPEND}
+ !sys-boot/netboot
+ !www-apps/nanoblogger
+"
+
+S="${WORKDIR}/nodebrain-${PV}"
+
+src_prepare() {
+ # fdl.texi is not included in the sources
+ sed -i \
+ -e '/@include fdl.texi/d' \
+ doc/nbTutorial/nbTutorial.texi || die
+
+ epatch "${FILESDIR}"/${PN}-0.8.14-include.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --include=/usr/include
+}
+
+src_compile() {
+ # Fails at parallel make
+ emake -j1
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+ dodoc AUTHORS NEWS README THANKS sample/*
+ dohtml html/*
+}
diff --git a/net-analyzer/nb/nb-0.9.03.ebuild b/net-analyzer/nb/nb-0.9.03.ebuild
new file mode 100644
index 000000000000..6aea0980d6f1
--- /dev/null
+++ b/net-analyzer/nb/nb-0.9.03.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Nodebrain is a tool to monitor and do event correlation"
+HOMEPAGE="http://nodebrain.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nodebrain/nodebrain-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static-libs"
+
+CDEPEND="dev-libs/libedit"
+DEPEND="
+ ${CDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig
+ sys-apps/texinfo
+"
+RDEPEND="
+ ${CDEPEND}
+ !sys-boot/netboot
+ !www-apps/nanoblogger
+"
+
+S="${WORKDIR}/nodebrain-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.8.14-include.patch
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --include=/usr/include
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+ dodoc AUTHORS NEWS README THANKS sample/*
+ dohtml html/*
+}