summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@integralblue.com>2017-01-23 09:52:08 -0500
committerDavid Seifert <soap@gentoo.org>2017-01-23 22:19:28 +0100
commit6b772bf4cab6d9a65e67519b9ee167e59331447c (patch)
tree6152c16e31bb7020e366ed2ad486df6a9cc4d47c /net-analyzer/netdata/netdata-1.5.0.ebuild
parentmedia-plugins/kodi-pvr-mythtv: version bump to 4.12.12 (diff)
downloadgentoo-6b772bf4cab6d9a65e67519b9ee167e59331447c.tar.gz
gentoo-6b772bf4cab6d9a65e67519b9ee167e59331447c.tar.bz2
gentoo-6b772bf4cab6d9a65e67519b9ee167e59331447c.zip
net-analyzer/netdata: version bump to 1.5.0
Closes: https://github.com/gentoo/gentoo/pull/3607
Diffstat (limited to 'net-analyzer/netdata/netdata-1.5.0.ebuild')
-rw-r--r--net-analyzer/netdata/netdata-1.5.0.ebuild102
1 files changed, 102 insertions, 0 deletions
diff --git a/net-analyzer/netdata/netdata-1.5.0.ebuild b/net-analyzer/netdata/netdata-1.5.0.ebuild
new file mode 100644
index 000000000000..ce0d866baa5e
--- /dev/null
+++ b/net-analyzer/netdata/netdata-1.5.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit autotools fcaps linux-info python-r1 systemd user
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/firehol/${PN}.git"
+ inherit git-r3
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/firehol/netdata/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Linux real time system monitoring, done right!"
+HOMEPAGE="https://github.com/firehol/netdata https://my-netdata.io/"
+
+LICENSE="GPL-3+ MIT BSD"
+SLOT="0"
+IUSE="+compression cpu_flags_x86_sse2 mysql nfacct nodejs postgres +python"
+REQUIRED_USE="
+ mysql? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+# most unconditional dependencies are for plugins.d/charts.d.plugin:
+RDEPEND="
+ >=app-shells/bash-4:0
+ net-misc/curl
+ net-misc/wget
+ virtual/awk
+ net-libs/libmnl
+ || ( net-analyzer/netcat6 net-analyzer/netcat )
+ net-analyzer/tcpdump
+ net-analyzer/traceroute
+ compression? ( sys-libs/zlib )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ mysql? (
+ || ( dev-python/mysqlclient[${PYTHON_USEDEP}] dev-python/mysql-python[${PYTHON_USEDEP}] )
+ )
+ postgres? (
+ dev-python/psycopg:2[${PYTHON_USEDEP}]
+ )
+ )
+ nfacct? (
+ net-firewall/nfacct
+ net-libs/libmnl
+ )
+ nodejs? (
+ net-libs/nodejs
+ )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+: ${NETDATA_USER:=netdata}
+: ${NETDATA_GROUP:=netdata}
+
+FILECAPS=(
+ 'cap_dac_read_search,cap_sys_ptrace+ep' 'usr/libexec/netdata/plugins.d/apps.plugin'
+)
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 / ${PN}
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --localstatedir="${EPREFIX}"/var \
+ --with-user=${NETDATA_USER} \
+ $(use_enable nfacct plugin-nfacct) \
+ $(use_enable cpu_flags_x86_sse2 x86-sse) \
+ $(use_with compression zlib)
+}
+
+src_install() {
+ default
+
+ fowners -Rc ${NETDATA_USER}:${NETDATA_GROUP} /var/log/netdata
+ fowners -Rc ${NETDATA_USER}:${NETDATA_GROUP} /var/cache/netdata
+ fowners -Rc ${NETDATA_USER}:${NETDATA_GROUP} /var/lib/netdata
+
+ fowners -Rc root:${NETDATA_GROUP} /usr/share/${PN}
+
+ newinitd system/netdata-openrc ${PN}
+ systemd_dounit system/netdata.service
+ insinto /etc/netdata
+ doins system/netdata.conf
+}